summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-12-12 03:21:45 +0000
committerTim Harder <radhermit@gentoo.org>2014-12-12 03:21:45 +0000
commit02b0def926c53a48c36b6acafb6c45ab3abaa7e6 (patch)
tree64aa0ebed67e3e1a34708e46e7b2cfce3c64a241 /dev-util/coccinelle
parentRemove old. (diff)
downloadgentoo-2-02b0def926c53a48c36b6acafb6c45ab3abaa7e6.tar.gz
gentoo-2-02b0def926c53a48c36b6acafb6c45ab3abaa7e6.tar.bz2
gentoo-2-02b0def926c53a48c36b6acafb6c45ab3abaa7e6.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-util/coccinelle')
-rw-r--r--dev-util/coccinelle/ChangeLog7
-rw-r--r--dev-util/coccinelle/coccinelle-1.0.0_rc23.ebuild132
2 files changed, 138 insertions, 1 deletions
diff --git a/dev-util/coccinelle/ChangeLog b/dev-util/coccinelle/ChangeLog
index 650f223c7ea2..b1dd4c11ba78 100644
--- a/dev-util/coccinelle/ChangeLog
+++ b/dev-util/coccinelle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/coccinelle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.35 2014/10/12 18:33:05 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.36 2014/12/12 03:21:45 radhermit Exp $
+
+*coccinelle-1.0.0_rc23 (12 Dec 2014)
+
+ 12 Dec 2014; Tim Harder <radhermit@gentoo.org> +coccinelle-1.0.0_rc23.ebuild:
+ Version bump.
*coccinelle-1.0.0_rc22 (12 Oct 2014)
diff --git a/dev-util/coccinelle/coccinelle-1.0.0_rc23.ebuild b/dev-util/coccinelle/coccinelle-1.0.0_rc23.ebuild
new file mode 100644
index 000000000000..c5c2ae0ba59c
--- /dev/null
+++ b/dev-util/coccinelle/coccinelle-1.0.0_rc23.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/coccinelle-1.0.0_rc23.ebuild,v 1.1 2014/12/12 03:21:45 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib eutils python-single-r1 bash-completion-r1 elisp-common autotools
+
+MY_P="${P/_/-}"
+DESCRIPTION="Program matching and transformation engine"
+HOMEPAGE="http://coccinelle.lip6.fr/"
+SRC_URI="http://coccinelle.lip6.fr/distrib/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# ocaml enables ocaml scripting (uses findlib)
+CDEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]
+ dev-ml/sexplib:=
+ emacs? ( virtual/emacs )
+ ocaml? ( dev-ml/findlib:= )
+ pcre? ( dev-ml/pcre-ocaml:= )
+ python? ( ${PYTHON_DEPS} )"
+
+RDEPEND="${CDEPEND}
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-fontsextra
+ )"
+
+REQUIRED_USE="test? ( ocaml python )"
+
+DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE=50coccinelle-gentoo.el
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if use python ; then
+ # fix python install location
+ sed -e "s:\$(SHAREDIR)/python:$(python_get_sitedir):" \
+ -e "s:PYTHON_TARGET:PYTHON_INSTALL_TARGET:" \
+ -i Makefile || die
+ fi
+
+ sed -i "s:^SHAREDIR=.*:SHAREDIR=/usr/$(get_libdir)/ocaml/${PN}/:" scripts/spatch.sh.in || die
+
+ epatch "${FILESDIR}"/${PN}-1.0.0_rc16-findtool.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ocaml) \
+ $(use_enable pcre) \
+ $(use_enable pcre pcre-syntax)
+
+ sed -e "s:^LIBDIR=.*:LIBDIR=/usr/$(get_libdir)/ocaml/stublibs/:" \
+ -e "s:^SHAREDIR=.*:SHAREDIR=/usr/$(get_libdir)/ocaml/${PN}/:" \
+ -i Makefile.config || die
+}
+
+src_compile() {
+ emake depend
+ emake
+
+ use ocamlopt && emake opt
+
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts emake docs
+ fi
+
+ if use emacs ; then
+ elisp-compile editors/emacs/cocci.el || die
+ fi
+}
+
+src_test() {
+ source env.sh # needed for built in-place python plugin
+ ./spatch standard.h -parse_c -dir tests/ || die
+ yes | ./spatch -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ if use ocamlopt ; then
+ ./spatch.opt -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ fi
+}
+
+src_install() {
+ default
+
+ use doc && dodoc docs/manual/*.pdf
+ newbashcomp scripts/spatch.bash_completion spatch
+
+ if use emacs ; then
+ elisp-install ${PN} editors/emacs/*
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ if use vim-syntax ; then
+ newdoc editors/vim/README README-vim
+ rm editors/vim/README || die
+ insinto /usr/share/vim/vimfiles
+ doins -r editors/vim/*
+ fi
+
+ use python && python_optimize
+
+ export STRIP_MASK='*/coccinelle/spatch'
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}