summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-10 06:43:47 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-10 06:43:47 +0000
commit7028fd4dd5f46d82fd381bb9b34f35050d104ba8 (patch)
tree52e1474f1a25bd0587b58fbf3b257e592002ebec /dev-util/cmake
parentMake bluetooth optional, bug #362613. (diff)
downloadgentoo-2-7028fd4dd5f46d82fd381bb9b34f35050d104ba8.tar.gz
gentoo-2-7028fd4dd5f46d82fd381bb9b34f35050d104ba8.tar.bz2
gentoo-2-7028fd4dd5f46d82fd381bb9b34f35050d104ba8.zip
Restore patch that was unfortunately dropped, bug #434524.
(Portage version: 2.2.0_alpha124/cvs/Linux i686)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog6
-rw-r--r--dev-util/cmake/files/cmake-2.8.4-FindPythonLibs.patch12
2 files changed, 17 insertions, 1 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index cb4629acf13e..2a1f57ca6a7e 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.217 2012/09/09 19:00:02 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.218 2012/09/10 06:43:47 johu Exp $
+
+ 10 Sep 2012; Johannes Huber <johu@gentoo.org>
+ +files/cmake-2.8.4-FindPythonLibs.patch:
+ Restore patch that was unfortunately dropped, bug #434524.
09 Sep 2012; Johannes Huber <johu@gentoo.org> -cmake-2.8.7-r5.ebuild,
-files/cmake-2.8.3-more-no_host_paths.patch,
diff --git a/dev-util/cmake/files/cmake-2.8.4-FindPythonLibs.patch b/dev-util/cmake/files/cmake-2.8.4-FindPythonLibs.patch
new file mode 100644
index 000000000000..28d2e4f87906
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.4-FindPythonLibs.patch
@@ -0,0 +1,12 @@
+diff -urN cmake-2.8.4.old/Modules/FindPythonLibs.cmake cmake-2.8.4/Modules/FindPythonLibs.cmake
+--- cmake-2.8.4.old/Modules/FindPythonLibs.cmake 2011-02-20 19:32:16.363655002 +0100
++++ cmake-2.8.4/Modules/FindPythonLibs.cmake 2011-02-20 19:33:51.905655001 +0100
+@@ -33,6 +33,8 @@
+ ${Python_ADDITIONAL_VERSIONS}
+ 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
+
++EXECUTE_PROCESS(COMMAND python -c "import sys; sys.stdout.write('.'.join([str(x) for x in sys.version_info[:2]]))"
++ OUTPUT_VARIABLE _Python_VERSIONS)
+ FOREACH(_CURRENT_VERSION ${_Python_VERSIONS})
+ STRING(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
+ IF(WIN32)