summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-11 20:38:42 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-11 20:38:42 +0000
commit4144f492baf7f80c06939c927c77a58e5ba4b923 (patch)
tree3248446c3345c66a2933c4ebe7e1bd7b71caaff4 /dev-util/checkstyle
parentclean out older ebuild with broken deps (diff)
downloadgentoo-2-4144f492baf7f80c06939c927c77a58e5ba4b923.tar.gz
gentoo-2-4144f492baf7f80c06939c927c77a58e5ba4b923.tar.bz2
gentoo-2-4144f492baf7f80c06939c927c77a58e5ba4b923.zip
Version bump using generation 2. Added source use flag and src_test support. Should fix bug #140831.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'dev-util/checkstyle')
-rw-r--r--dev-util/checkstyle/ChangeLog8
-rw-r--r--dev-util/checkstyle/checkstyle-4.2.ebuild97
-rw-r--r--dev-util/checkstyle/files/digest-checkstyle-3.52
-rw-r--r--dev-util/checkstyle/files/digest-checkstyle-4.12
-rw-r--r--dev-util/checkstyle/files/digest-checkstyle-4.23
5 files changed, 111 insertions, 1 deletions
diff --git a/dev-util/checkstyle/ChangeLog b/dev-util/checkstyle/ChangeLog
index 99b86514f0e5..7f99934c72a5 100644
--- a/dev-util/checkstyle/ChangeLog
+++ b/dev-util/checkstyle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/checkstyle
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/ChangeLog,v 1.20 2007/01/09 15:34:36 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/ChangeLog,v 1.21 2007/01/11 20:38:42 betelgeuse Exp $
+
+*checkstyle-4.2 (12 Jan 2007)
+
+ 12 Jan 2007; Petteri Räty <betelgeuse@gentoo.org> +checkstyle-4.2.ebuild:
+ Version bump using generation 2. Added source use flag and src_test support.
+ Should fix bug #140831.
09 Jan 2007; Vlastimil Babka <caster@gentoo.org> checkstyle-4.1.ebuild:
Convert einfo to elog.
diff --git a/dev-util/checkstyle/checkstyle-4.2.ebuild b/dev-util/checkstyle/checkstyle-4.2.ebuild
new file mode 100644
index 000000000000..0d39073981a3
--- /dev/null
+++ b/dev-util/checkstyle/checkstyle-4.2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/checkstyle-4.2.ebuild,v 1.1 2007/01/11 20:38:42 betelgeuse Exp $
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="A development tool to help programmers write Java code that adheres to a coding standard."
+HOMEPAGE="http://checkstyle.sourceforge.net"
+SRC_URI="mirror://sourceforge/checkstyle/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc source test"
+
+COMMON_DEP="
+ dev-java/antlr
+ =dev-java/commons-beanutils-1.7*
+ =dev-java/commons-cli-1*
+ dev-java/commons-logging"
+
+RDEPEND="
+ !test? ( >=virtual/jre-1.4 )
+ test? ( >=virtual/jre-1.5 )
+ ${COMMON_DEP}"
+
+# Uses antlr and as such needs ant-tasks
+# Tests only pass with 1.5 but I think that
+# is a problem with the test classes so running
+# with 1.6 should be fine
+DEPEND="
+ !test? ( >=virtual/jdk-1.4 )
+ test? ( =virtual/jdk-1.5* )
+ ${COMMON_DEP}
+ dev-java/ant-core
+ dev-java/ant-tasks
+ test? (
+ dev-java/junit
+ dev-java/emma
+ )"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/lib
+ rm *.jar
+ java-pkg_jar-from antlr
+ java-pkg_jar-from commons-beanutils-1.7
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from commons-logging
+}
+
+src_compile() {
+ eant compile.checkstyle $(use_doc)
+ jar cfm ${PN}.jar config/manifest.mf -C target/checkstyle . || die "jar failed"
+}
+
+src_test() {
+ cd "${S}/lib"
+ java-pkg_jar-from --build-only junit
+ # for some weird classpath interactions both seem to be needed
+ java-pkg_jar-from --build-only emma
+ cd "${S}"
+ local cp=$(java-pkg_getjar --build-only emma emma.jar)
+ eant run.tests -lib "${cp}"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ dodoc README RIGHTS.antlr || die
+ use doc && java-pkg_dojavadoc target/docs/api
+ use source && java-pkg_dosrc src/${PN}/com
+
+ # Install check files
+ insinto /usr/share/checkstyle/checks
+ for file in *.xml; do
+ [[ "${file}" != build.xml ]] && doins ${file}
+ done
+
+ # Install extra files
+ insinto /usr/share/checkstyle/contrib
+ doins -r contrib/*
+
+ java-pkg_dolauncher ${PN} \
+ --main com.puppycrawl.tools.checkstyle.Main
+
+ # Make the ant tasks available to ant
+ dodir /usr/share/ant-core/lib
+ dosym /usr/share/${PN}/lib/${PN}.jar /usr/share/ant-core/lib/
+}
+
+pkg_postinst() {
+ elog "Checkstyle is located at /usr/bin/checkstyle"
+ elog "Check files are located in /usr/share/checkstyle/checks/"
+}
diff --git a/dev-util/checkstyle/files/digest-checkstyle-3.5 b/dev-util/checkstyle/files/digest-checkstyle-3.5
index 7868b2be8029..80f6450ca642 100644
--- a/dev-util/checkstyle/files/digest-checkstyle-3.5
+++ b/dev-util/checkstyle/files/digest-checkstyle-3.5
@@ -1 +1,3 @@
MD5 868736a6617d58bbc4efcf85984423fd checkstyle-src-3.5.tar.gz 1962069
+RMD160 4a62c11b40bb32cb1519e3ef78120d6b0c860c48 checkstyle-src-3.5.tar.gz 1962069
+SHA256 f72fc6724699c617b544cc9b4925a0e568106c8c445da43775d5451becccf2d2 checkstyle-src-3.5.tar.gz 1962069
diff --git a/dev-util/checkstyle/files/digest-checkstyle-4.1 b/dev-util/checkstyle/files/digest-checkstyle-4.1
index bababbc30bb3..d3be6a690f8b 100644
--- a/dev-util/checkstyle/files/digest-checkstyle-4.1
+++ b/dev-util/checkstyle/files/digest-checkstyle-4.1
@@ -1 +1,3 @@
MD5 96b430fe5087b4f62fa78804475ee2ea checkstyle-src-4.1.tar.gz 2877441
+RMD160 70be504829eb9f33affe56bd4b87228a38354683 checkstyle-src-4.1.tar.gz 2877441
+SHA256 0ea1c7fea315a8321a826ccf8e4fa9b12542d79a9d6da5f79def8c77f9e5fddb checkstyle-src-4.1.tar.gz 2877441
diff --git a/dev-util/checkstyle/files/digest-checkstyle-4.2 b/dev-util/checkstyle/files/digest-checkstyle-4.2
new file mode 100644
index 000000000000..413e54f19d57
--- /dev/null
+++ b/dev-util/checkstyle/files/digest-checkstyle-4.2
@@ -0,0 +1,3 @@
+MD5 c75e395b2cf7dc103f4a23bcd15dc545 checkstyle-src-4.2.tar.gz 2558813
+RMD160 02a248be429700cc27cf17d786dce29ed6e03189 checkstyle-src-4.2.tar.gz 2558813
+SHA256 9765dfa9f2d8d1780a90f792481d48cb90d671a22ba9be4ad026b9dbf83b0aa1 checkstyle-src-4.2.tar.gz 2558813