summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-08 21:29:38 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-08 21:29:38 +0000
commitb8032324f29095a86b1b126724278d36a744b6e4 (patch)
tree0d81afbe4e77e231e0fa5d08987232e4af18ad1f /dev-util/ccache
parentVersion bumps (diff)
downloadgentoo-2-b8032324f29095a86b1b126724278d36a744b6e4.tar.gz
gentoo-2-b8032324f29095a86b1b126724278d36a744b6e4.tar.bz2
gentoo-2-b8032324f29095a86b1b126724278d36a744b6e4.zip
Use `command` rather than `type` #503428 by Naohiro Aota.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog5
-rw-r--r--dev-util/ccache/files/ccache-config-216
2 files changed, 12 insertions, 9 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index b5c13aa254d0..8eb16479270f 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/ccache
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.137 2014/01/26 12:13:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.138 2014/03/08 21:29:38 vapier Exp $
+
+ 08 Mar 2014; Mike Frysinger <vapier@gentoo.org> files/ccache-config-2:
+ Use `command` rather than `type` #503428 by Naohiro Aota.
26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ccache-3.1.9-r3.ebuild:
Stable for sparc, wrt bug #495658
diff --git a/dev-util/ccache/files/ccache-config-2 b/dev-util/ccache/files/ccache-config-2
index e00e7b6c88fd..9253e6eff784 100644
--- a/dev-util/ccache/files/ccache-config-2
+++ b/dev-util/ccache/files/ccache-config-2
@@ -2,8 +2,8 @@
#
# ccache-config - helper script for ccache and its ebuild
#
-# Copyright 2003-2013 Superlucidity Services, LLC
-# Copyright 2013 Gentoo Foundation
+# Copyright 2003-2014 Superlucidity Services, LLC
+# Copyright 2013-2014 Gentoo Foundation
# This program licensed under the GNU GPL version 2.
#
# This script developed by Zachary T Welch at Superlucidity Services, LLC
@@ -54,10 +54,10 @@ cc_install_link() {
# Search the PATH for the specified compiler
# then create shadow link in /usr/lib/ccache/bin to ccache
- if [ -n "$(type -p ${1})" ]; then
+ if command -v "$1" >/dev/null ; then
# first be sure any old link is removed
_CC_QUIET=1
- cc_remove_link "${1}"
+ cc_remove_link "$1"
unset _CC_QUIET
# then create the new link
@@ -77,14 +77,14 @@ cc_links() {
###
# main routine
-case "${1}" in
+case $1 in
--install-links )
- cc_links install "${2}"
+ cc_links install "$2"
;;
--remove-links )
- cc_links remove "${2}"
+ cc_links remove "$2"
;;
* )
- echo "usage: ${0} {--install-links|--remove-links} [ CHOST ]"
+ echo "usage: $0 {--install-links|--remove-links} [ CHOST ]"
;;
esac