summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-08-02 14:20:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-08-02 14:20:19 +0000
commitc729564de077b109d69e91ee03686b7a6d8099d6 (patch)
treebc2523d4308407e8f888ab3467a4adaec974492c /dev-util/catfish
parentVersion bump and remove old (diff)
downloadgentoo-2-c729564de077b109d69e91ee03686b7a6d8099d6.tar.gz
gentoo-2-c729564de077b109d69e91ee03686b7a6d8099d6.tar.bz2
gentoo-2-c729564de077b109d69e91ee03686b7a6d8099d6.zip
Import 30Fix_tracker_backend.dpatch (and 40Fix_gtkiconload.dpatch) from Debian in order to be compatible with current app-misc/tracker wrt #429382 by Kai Wüstermann
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/ChangeLog11
-rw-r--r--dev-util/catfish/catfish-0.3.2-r1.ebuild68
-rw-r--r--dev-util/catfish/files/catfish-0.3.2-fix_gtkiconload.patch20
-rw-r--r--dev-util/catfish/files/catfish-0.3.2-fix_tracker_backend.patch12
4 files changed, 110 insertions, 1 deletions
diff --git a/dev-util/catfish/ChangeLog b/dev-util/catfish/ChangeLog
index de7a4ad81277..65ce74f39bbd 100644
--- a/dev-util/catfish/ChangeLog
+++ b/dev-util/catfish/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/catfish
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/ChangeLog,v 1.2 2012/02/05 01:41:24 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/ChangeLog,v 1.3 2012/08/02 14:20:19 ssuominen Exp $
+
+*catfish-0.3.2-r1 (02 Aug 2012)
+
+ 02 Aug 2012; Samuli Suominen <ssuominen@gentoo.org> +catfish-0.3.2-r1.ebuild,
+ +files/catfish-0.3.2-fix_gtkiconload.patch,
+ +files/catfish-0.3.2-fix_tracker_backend.patch:
+ Import 30Fix_tracker_backend.dpatch (and 40Fix_gtkiconload.dpatch) from
+ Debian in order to be compatible with current app-misc/tracker wrt #429382 by
+ Kai Wüstermann
05 Feb 2012; Mike Gilbert <floppym@gentoo.org> catfish-0.3.2.ebuild:
Inherit multilib.
diff --git a/dev-util/catfish/catfish-0.3.2-r1.ebuild b/dev-util/catfish/catfish-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..215aba9ef7a1
--- /dev/null
+++ b/dev-util/catfish/catfish-0.3.2-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/catfish-0.3.2-r1.ebuild,v 1.1 2012/08/02 14:20:19 ssuominen Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.7"
+inherit eutils gnome2-utils multilib python
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="http://software.twotoasts.de/index.php?/pages/catfish_summary.html"
+SRC_URI="http://www.twotoasts.de/media/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python
+ >=dev-python/pygtk-2
+ dev-python/pyxdg"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-gentoo.patch \
+ "${FILESDIR}"/${P}-fix_tracker_backend.patch \
+ "${FILESDIR}"/${P}-fix_gtkiconload.patch
+
+ python_convert_shebangs 2 {build,catfish}.py
+
+ cat <<-EOF > "${T}"/${PN}
+ #!/bin/sh
+ cd /usr/$(get_libdir)/${PN}
+ python2 ${PN}.pyc "\$@"
+ EOF
+}
+
+src_configure() {
+ ./configure --prefix=/usr || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install
+
+ dobin "${T}"/${PN}
+
+ dodoc AUTHORS ChangeLog README TODO
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+ gnome2_icon_cache_update
+}
diff --git a/dev-util/catfish/files/catfish-0.3.2-fix_gtkiconload.patch b/dev-util/catfish/files/catfish-0.3.2-fix_gtkiconload.patch
new file mode 100644
index 000000000000..b8e7434eb416
--- /dev/null
+++ b/dev-util/catfish/files/catfish-0.3.2-fix_gtkiconload.patch
@@ -0,0 +1,20 @@
+http://patch-tracker.debian.org/patch/series/view/catfish/0.3.2-2/40Fix_gtkiconload.dpatch
+
+--- catfish.py
++++ catfish.py
+@@ -707,9 +707,12 @@
+ return self.icon_cache[name]
+ except KeyError:
+ icon_size = gtk.icon_size_lookup(icon_size)[0]
+- icon = self.icon_theme.load_icon(name, icon_size, 0)
+- self.icon_cache[name] = icon
+- return icon
++ try:
++ icon = self.icon_theme.load_icon(name, icon_size, 0)
++ self.icon_cache[name] = icon
++ return icon
++ except gobject.GError:
++ return
+
+ def get_thumbnail(self, path, icon_size=0, mime_type=None):
+ """Try to fetch a small thumbnail."""
diff --git a/dev-util/catfish/files/catfish-0.3.2-fix_tracker_backend.patch b/dev-util/catfish/files/catfish-0.3.2-fix_tracker_backend.patch
new file mode 100644
index 000000000000..5015784cf954
--- /dev/null
+++ b/dev-util/catfish/files/catfish-0.3.2-fix_tracker_backend.patch
@@ -0,0 +1,12 @@
+http://patch-tracker.debian.org/patch/series/view/catfish/0.3.2-2/30Fix_tracker_backend.dpatch
+
+--- catfish.py
++++ catfish.py
+@@ -629,6 +629,7 @@
+ if self.options.debug: print 'Debug:', msg
+ query = generic_query()
+ for filename in query.run(keywords, folder, exact, hidden, limit):
++ filename = filename.strip()
+ if self.abort_find or len(listmodel) == limit: break
+ filename = filename.split(os.linesep)[0]
+ # Convert uris to filenames