summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-09-06 17:43:50 +0000
committerMichael Weber <xmw@gentoo.org>2010-09-06 17:43:50 +0000
commitee8eb185ed22de21e5e695f9993b4f4837f3377a (patch)
treed71cfe611789a8a2de3cbdf9b4fe3a182e23d710 /dev-util/byacc
parentFix license by Alon Bar-Lev (bug #336227). (diff)
downloadgentoo-2-ee8eb185ed22de21e5e695f9993b4f4837f3377a.tar.gz
gentoo-2-ee8eb185ed22de21e5e695f9993b4f4837f3377a.tar.bz2
gentoo-2-ee8eb185ed22de21e5e695f9993b4f4837f3377a.zip
Rev bump to fix LDFLAGS (bug #336197)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/byacc')
-rw-r--r--dev-util/byacc/ChangeLog7
-rw-r--r--dev-util/byacc/byacc-1.9-r3.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-util/byacc/ChangeLog b/dev-util/byacc/ChangeLog
index aaa85b38435c..c77cf4663c10 100644
--- a/dev-util/byacc/ChangeLog
+++ b/dev-util/byacc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/byacc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/ChangeLog,v 1.23 2010/01/15 21:11:02 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/ChangeLog,v 1.24 2010/09/06 17:43:50 xmw Exp $
+
+*byacc-1.9-r3 (06 Sep 2010)
+
+ 06 Sep 2010; Michael Weber <xmw@gentoo.org> +byacc-1.9-r3.ebuild:
+ Rev bump to fix LDFLAGS (bug #336197).
15 Jan 2010; Christian Faulhammer <fauli@gentoo.org> byacc-1.9-r2.ebuild:
Transfer Prefix keywords
diff --git a/dev-util/byacc/byacc-1.9-r3.ebuild b/dev-util/byacc/byacc-1.9-r3.ebuild
new file mode 100644
index 000000000000..c33bdde50496
--- /dev/null
+++ b/dev-util/byacc/byacc-1.9-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/byacc-1.9-r3.ebuild,v 1.1 2010/09/06 17:43:50 xmw Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="the best variant of the Yacc parser generator"
+HOMEPAGE="http://dickey.his.com/byacc/byacc.html"
+SRC_URI="http://sources.isc.org/devel/tools/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/mkstemp.patch
+
+ # The following patch fixes yacc to run correctly on ia64 (and
+ # other 64-bit arches). See bug 46233
+ epatch "${FILESDIR}"/byacc-1.9-ia64.patch
+
+ # avoid stack access error, bug 232005
+ epatch "${FILESDIR}"/${P}-CVE-2008-3196.patch
+}
+
+src_compile() {
+ emake PROGRAM=byacc CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin byacc || die
+ mv yacc.1 byacc.1 || die
+ doman byacc.1 || die
+ dodoc ACKNOWLEDGEMENTS MANIFEST NEW_FEATURES NOTES README || die
+}