summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-07-31 07:38:30 +0000
committerJason Zaman <perfinion@gentoo.org>2015-07-31 07:38:30 +0000
commitb73ca09f322d819a74a4677f38c2af6381d34b7a (patch)
treedb227297ff4e5aeea2e317aaab3cb84dac8042b6 /dev-util/android-studio
parentInitial import from pentoo overlay. New dependency for net-analyzer/metasploit. (diff)
downloadgentoo-2-b73ca09f322d819a74a4677f38c2af6381d34b7a.tar.gz
gentoo-2-b73ca09f322d819a74a4677f38c2af6381d34b7a.tar.bz2
gentoo-2-b73ca09f322d819a74a4677f38c2af6381d34b7a.zip
stabilize, drop old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x7EF137EC935B0EAF)
Diffstat (limited to 'dev-util/android-studio')
-rw-r--r--dev-util/android-studio/ChangeLog7
-rw-r--r--dev-util/android-studio/android-studio-1.2.1.1.141.1903250.ebuild62
-rw-r--r--dev-util/android-studio/android-studio-1.2.2.0.141.1980579.ebuild4
3 files changed, 8 insertions, 65 deletions
diff --git a/dev-util/android-studio/ChangeLog b/dev-util/android-studio/ChangeLog
index 7f7712e30d86..80832170efed 100644
--- a/dev-util/android-studio/ChangeLog
+++ b/dev-util/android-studio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/android-studio
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/android-studio/ChangeLog,v 1.21 2015/07/31 07:36:20 perfinion Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/android-studio/ChangeLog,v 1.22 2015/07/31 07:38:30 perfinion Exp $
+
+ 31 Jul 2015; Jason Zaman <perfinion@gentoo.org>
+ -android-studio-1.2.1.1.141.1903250.ebuild,
+ android-studio-1.2.2.0.141.1980579.ebuild:
+ stabilize, drop old
*android-studio-1.3.0.10.141.2117773 (31 Jul 2015)
diff --git a/dev-util/android-studio/android-studio-1.2.1.1.141.1903250.ebuild b/dev-util/android-studio/android-studio-1.2.1.1.141.1903250.ebuild
deleted file mode 100644
index 16af7b9df20f..000000000000
--- a/dev-util/android-studio/android-studio-1.2.1.1.141.1903250.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/android-studio/android-studio-1.2.1.1.141.1903250.ebuild,v 1.1 2015/06/01 15:30:53 perfinion Exp $
-
-EAPI=5
-inherit eutils versionator
-
-RESTRICT="strip"
-QA_PREBUILT="opt/${PN}/bin/libbreakgen.so"
-if [[ $(get_version_component_count) -eq 6 ]]; then
- STUDIO_V=$(get_version_component_range 1-4)
- BUILD_V=$(get_version_component_range 5-6)
-else
- STUDIO_V=$(get_version_component_range 1-3)
- BUILD_V=$(get_version_component_range 4-5)
-fi
-
-DESCRIPTION="A new Android development environment based on IntelliJ IDEA"
-HOMEPAGE="http://developer.android.com/sdk/installing/studio.html"
-SRC_URI="http://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="selinux"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="app-arch/zip"
-RDEPEND=">=virtual/jdk-1.7
- selinux? ( sec-policy/selinux-android )
- >=app-arch/bzip2-1.0.6-r4[abi_x86_32(-)]
- >=dev-libs/expat-2.1.0-r3[abi_x86_32(-)]
- >=dev-libs/libffi-3.0.13-r1[abi_x86_32(-)]
- >=media-libs/fontconfig-2.10.92[abi_x86_32(-)]
- >=media-libs/freetype-2.5.5[abi_x86_32(-)]
- >=media-libs/libpng-1.2.51[abi_x86_32(-)]
- >=media-libs/mesa-10.2.8[abi_x86_32(-)]
- >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)]
- >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
- >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
- >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)]
- >=x11-libs/libXdamage-1.1.4-r1[abi_x86_32(-)]
- >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
- >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
- >=x11-libs/libXfixes-5.0.1[abi_x86_32(-)]
- >=x11-libs/libXrender-0.9.8[abi_x86_32(-)]
- >=x11-libs/libXxf86vm-1.1.3[abi_x86_32(-)]
- >=x11-libs/libdrm-2.4.46[abi_x86_32(-)]
- >=x11-libs/libxcb-1.9.1[abi_x86_32(-)]
- >=x11-libs/libxshmfence-1.1[abi_x86_32(-)]"
-S=${WORKDIR}/${PN}
-
-src_install() {
- local dir="/opt/${PN}"
-
- insinto "${dir}"
- doins -r *
- fperms 755 "${dir}/bin/studio.sh" "${dir}/bin/fsnotifier" "${dir}/bin/fsnotifier64"
-
- newicon "bin/studio.png" "${PN}.png"
- make_wrapper ${PN} ${dir}/bin/studio.sh
- make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE"
-}
diff --git a/dev-util/android-studio/android-studio-1.2.2.0.141.1980579.ebuild b/dev-util/android-studio/android-studio-1.2.2.0.141.1980579.ebuild
index d168589308d6..790714e28721 100644
--- a/dev-util/android-studio/android-studio-1.2.2.0.141.1980579.ebuild
+++ b/dev-util/android-studio/android-studio-1.2.2.0.141.1980579.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/android-studio/android-studio-1.2.2.0.141.1980579.ebuild,v 1.1 2015/06/17 10:38:42 perfinion Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/android-studio/android-studio-1.2.2.0.141.1980579.ebuild,v 1.2 2015/07/31 07:38:30 perfinion Exp $
EAPI=5
inherit eutils versionator
@@ -22,7 +22,7 @@ SRC_URI="http://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-$
LICENSE="Apache-2.0"
SLOT="0"
IUSE="selinux"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
DEPEND="app-arch/zip"
RDEPEND=">=virtual/jdk-1.7