summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-05-18 14:27:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-05-18 14:27:41 +0000
commit69bd0d9ee55bd2492f2ed04c167f1a17e8f552c9 (patch)
treede69ad490b6fe0d3302212abbb2b23c272a241da /dev-texlive
parentnew upstream release. (diff)
downloadgentoo-2-69bd0d9ee55bd2492f2ed04c167f1a17e8f552c9.tar.gz
gentoo-2-69bd0d9ee55bd2492f2ed04c167f1a17e8f552c9.tar.bz2
gentoo-2-69bd0d9ee55bd2492f2ed04c167f1a17e8f552c9.zip
fix luatools with luatex 0.65, based on https://github.com/mpg/lualibs/commit/ebac0e8e8d5d57eec5dfd3a3217e7e2fc3fe9bbd#lualibs-dir.lua
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'dev-texlive')
-rw-r--r--dev-texlive/texlive-context/ChangeLog10
-rw-r--r--dev-texlive/texlive-context/files/luatools.patch43
-rw-r--r--dev-texlive/texlive-context/texlive-context-2010-r1.ebuild52
3 files changed, 104 insertions, 1 deletions
diff --git a/dev-texlive/texlive-context/ChangeLog b/dev-texlive/texlive-context/ChangeLog
index f8579e08750e..c96bc5a1a907 100644
--- a/dev-texlive/texlive-context/ChangeLog
+++ b/dev-texlive/texlive-context/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-texlive/texlive-context
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-context/ChangeLog,v 1.39 2011/02/09 19:38:38 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-context/ChangeLog,v 1.40 2011/05/18 14:27:41 aballier Exp $
+
+*texlive-context-2010-r1 (18 May 2011)
+
+ 18 May 2011; Alexis Ballier <aballier@gentoo.org>
+ +texlive-context-2010-r1.ebuild, +files/luatools.patch:
+ fix luatools with luatex 0.65, based on
+ https://github.com/mpg/lualibs/commit/ebac0e8e8d5d57eec5dfd3a3217e7e2fc3fe9bb
+ d#lualibs-dir.lua
09 Feb 2011; Alexis Ballier <aballier@gentoo.org>
texlive-context-2010.ebuild:
diff --git a/dev-texlive/texlive-context/files/luatools.patch b/dev-texlive/texlive-context/files/luatools.patch
new file mode 100644
index 000000000000..20e2cf4e5b5c
--- /dev/null
+++ b/dev-texlive/texlive-context/files/luatools.patch
@@ -0,0 +1,43 @@
+--- texmf-dist/scripts/context/stubs/unix/luatools 2010-06-11 01:27:28.000000000 -0400
++++ texmf-dist/scripts/context/stubs/unix/luatools.new 2011-05-18 10:21:42.575032665 -0400
+@@ -2723,15 +2723,15 @@
+ local walkdir = lfs.dir
+
+ local function glob_pattern(path,patt,recurse,action)
+- local ok, scanner
++ local ok, scanner, dirobj
+ if path == "/" then
+- ok, scanner = xpcall(function() return walkdir(path..".") end, function() end) -- kepler safe
++ ok, scanner, dirobj = xpcall(function() return walkdir(path..".") end, function() end) -- kepler safe
+ else
+- ok, scanner = xpcall(function() return walkdir(path) end, function() end) -- kepler safe
++ ok, scanner, dirobj = xpcall(function() return walkdir(path) end, function() end) -- kepler safe
+ end
+ if ok and type(scanner) == "function" then
+ if not find(path,"/$") then path = path .. '/' end
+- for name in scanner do
++ for name in scanner, dirobj do
+ local full = path .. name
+ local mode = attributes(full,'mode')
+ if mode == 'file' then
+@@ -2748,16 +2748,16 @@
+ dir.glob_pattern = glob_pattern
+
+ local function collect_pattern(path,patt,recurse,result)
+- local ok, scanner
++ local ok, scanner, dirobj
+ result = result or { }
+ if path == "/" then
+- ok, scanner = xpcall(function() return walkdir(path..".") end, function() end) -- kepler safe
++ ok, scanner, dirobj = xpcall(function() return walkdir(path..".") end, function() end) -- kepler safe
+ else
+- ok, scanner = xpcall(function() return walkdir(path) end, function() end) -- kepler safe
++ ok, scanner, dirobj = xpcall(function() return walkdir(path) end, function() end) -- kepler safe
+ end
+ if ok and type(scanner) == "function" then
+ if not find(path,"/$") then path = path .. '/' end
+- for name in scanner do
++ for name in scanner, dirobj do
+ local full = path .. name
+ local attr = attributes(full)
+ local mode = attr.mode
diff --git a/dev-texlive/texlive-context/texlive-context-2010-r1.ebuild b/dev-texlive/texlive-context/texlive-context-2010-r1.ebuild
new file mode 100644
index 000000000000..767c119a1468
--- /dev/null
+++ b/dev-texlive/texlive-context/texlive-context-2010-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-context/texlive-context-2010-r1.ebuild,v 1.1 2011/05/18 14:27:41 aballier Exp $
+
+EAPI="3"
+
+TEXLIVE_MODULE_CONTENTS="context jmn lmextra context-account context-algorithmic context-bnf context-chromato context-construction-plan context-degrade context-filter context-fixme context-french context-fullpage context-games context-gnuplot context-letter context-lettrine context-lilypond context-mathsets context-notes-zh-cn context-ruby context-simplefonts context-simpleslides context-top-ten context-typearea context-typescripts context-vim collection-context
+"
+TEXLIVE_MODULE_DOC_CONTENTS="context.doc context-account.doc context-bnf.doc context-chromato.doc context-construction-plan.doc context-degrade.doc context-filter.doc context-fixme.doc context-french.doc context-fullpage.doc context-games.doc context-letter.doc context-lettrine.doc context-lilypond.doc context-mathsets.doc context-notes-zh-cn.doc context-ruby.doc context-simplefonts.doc context-simpleslides.doc context-top-ten.doc context-typearea.doc context-typescripts.doc context-vim.doc "
+TEXLIVE_MODULE_SRC_CONTENTS="context-fixme.source context-letter.source context-simplefonts.source "
+inherit texlive-module
+DESCRIPTION="TeXLive ConTeXt format"
+
+LICENSE="GPL-2 as-is FDL-1.1 GPL-1 GPL-2 public-domain "
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+DEPEND=">=dev-texlive/texlive-basic-2010
+>=dev-texlive/texlive-latex-2010
+!<dev-texlive/texlive-latex-2010
+>=app-text/texlive-core-2010[xetex]
+>=dev-texlive/texlive-metapost-2010
+"
+RDEPEND="${DEPEND} dev-lang/ruby
+"
+TL_CONTEXT_UNIX_STUBS="context ctxtools luatools mtxrun pstopdf rlxtools texexec texmfstart"
+TEXLIVE_MODULE_BINSCRIPTS=""
+for i in ${TL_CONTEXT_UNIX_STUBS} ; do
+TEXLIVE_MODULE_BINSCRIPTS="${TEXLIVE_MODULE_BINSCRIPTS} texmf-dist/scripts/context/stubs/unix/$i"
+done
+
+# This small hack is needed in order to have a sane upgrade path:
+# the new TeX Live 2009 metapost produces this file but it is not recorded in
+# any package; when running fmtutil (like texmf-update does) this file will be
+# created and cause collisions.
+
+pkg_setup() {
+ if [ -f "${ROOT}/var/lib/texmf/web2c/metapost/metafun.log" ]; then
+ einfo "Removing ${ROOT}/var/lib/texmf/web2c/metapost/metafun.log"
+ rm -f "${ROOT}/var/lib/texmf/web2c/metapost/metafun.log"
+ fi
+}
+
+TL_MODULE_INFORMATION="For using ConTeXt mkII simply use 'texexec' to generate
+your documents.
+If you plan to use mkIV and its 'context' command to generate your documents,
+you have to run 'luatools --generate' as normal user before first use.
+
+More information and advanced options on:
+http://wiki.contextgarden.net/TeX_Live_2010"
+
+PATCHES=( "${FILESDIR}/luatools.patch" )