summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-08-16 21:48:13 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-08-16 21:48:13 +0000
commit3c6d0c47b57550a3c51f9f2c0b7d175d916cc3aa (patch)
tree5c2e3561eacabe87d1c8687e8876136ebdb7cd81 /dev-tcltk/tclx
parentUpdated ChangeLog. (diff)
downloadgentoo-2-3c6d0c47b57550a3c51f9f2c0b7d175d916cc3aa.tar.gz
gentoo-2-3c6d0c47b57550a3c51f9f2c0b7d175d916cc3aa.tar.bz2
gentoo-2-3c6d0c47b57550a3c51f9f2c0b7d175d916cc3aa.zip
made tk dependency optional (on X)
Diffstat (limited to 'dev-tcltk/tclx')
-rw-r--r--dev-tcltk/tclx/ChangeLog17
-rw-r--r--dev-tcltk/tclx/tclx-8.3.ebuild37
2 files changed, 35 insertions, 19 deletions
diff --git a/dev-tcltk/tclx/ChangeLog b/dev-tcltk/tclx/ChangeLog
index 1fa254f377ce..cfd7efc35606 100644
--- a/dev-tcltk/tclx/ChangeLog
+++ b/dev-tcltk/tclx/ChangeLog
@@ -1,8 +1,23 @@
# ChangeLog for dev-tcltk/tclx
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/ChangeLog,v 1.1 2002/08/15 00:23:58 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/ChangeLog,v 1.2 2002/08/16 21:48:13 george Exp $
*tclx-8.3 (15 Aug 2002)
+ 16 Aug 2002; George Shapovalov <george@gentoo.org> tclx-8.3.ebuild :
+
+ incorporated modification by <pcgod@gmx.net> to make tk dependency optional (if
+ X is defined)
+ Also moved long description into ChangeLog, leaving a one-liner in the ebuild
+
+
15 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> tclx-8.3.ebuild :
Initial import. Ebuild submitted by Chris Bainbridge <chrb@dcs.ed.ac.uk>.
+
+ short description:
+ A set of extensions to TCL oriented towards common
+ UNIX/Linux programming tasks. TclX enhances Tcl support for files,
+ network access, debugging, math, lists, and message catalogs, provides
+ additional interfaces to the native operating system, as well as many
+ new programming constructs, text manipulation tools, and debugging
+ capabilities
diff --git a/dev-tcltk/tclx/tclx-8.3.ebuild b/dev-tcltk/tclx/tclx-8.3.ebuild
index 910ad8c0667d..d8441bfd399d 100644
--- a/dev-tcltk/tclx/tclx-8.3.ebuild
+++ b/dev-tcltk/tclx/tclx-8.3.ebuild
@@ -1,23 +1,20 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3.ebuild,v 1.1 2002/08/15 00:23:58 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3.ebuild,v 1.2 2002/08/16 21:48:13 george Exp $
-DESCRIPTION="A set of extensions to TCL oriented towards common
-UNIX/Linux programming tasks. TclX enhances Tcl support for files,
-network access, debugging, math, lists, and message catalogs, provides
-additional interfaces to the native operating system, as well as many
-new programming constructs, text manipulation tools, and debugging
-capabilities"
+DESCRIPTION="A set of extensions to TCL"
HOMEPAGE="http://www.neosoft.com/TclX/"
SRC_URI="ftp://ftp.slackware.com/pub/slackware/slackware-8.1/source/tcl/tclx/${PN}${PV}.tar.gz
ftp://ftp.scriptics.com/pub/tcl/tcl8_3/tcl8.3.3.tar.gz
ftp://ftp.scriptics.com/pub/tcl/tcl8_3/tk8.3.3.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
-DEPEND="=dev-lang/tk-8.3*
- =dev-lang/tcl-8.3*"
+
+DEPEND="=dev-lang/tcl-8.3*
+ X? =dev-lang/tk-8.3*"
RDEPEND=${DEPEND}
S=${WORKDIR}/${PN}${PV}
@@ -37,19 +34,23 @@ src_compile() {
|| die
emake CFLAGS="${CFLAGS}" || die
- # configure and build tk
- cd ${WORKDIR}/tk8.3.3/unix
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- || die
- emake CFLAGS="${CFLAGS}" || die
-
+ use X && ( \
+ # configure and build tk
+ cd ${WORKDIR}/tk8.3.3/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die
+ emake CFLAGS="${CFLAGS}" || die
+ )
+
+ use X && myconf="--with-tk=${WORKDIR}/tk8.3.3/unix" || myconf="--enable-tk=no"
+
# configure and build tclx
cd ${S}/unix
./configure \
--with-tcl=${WORKDIR}/tcl8.3.3/unix \
- --with-tk=${WORKDIR}/tk8.3.3/unix \
+ ${myconf} \
--enable-shared \
--host=${CHOST} \
--prefix=/usr \