summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-04-16 19:13:18 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-04-16 19:13:18 +0000
commitdf72d1289d2eda0b4ef28293a8b66610ec4bc4a2 (patch)
tree1408560abfd28e162073529cd8b8e1251b353a1b /dev-tcltk/tclpython
parentStable for HPPA (bug #265780). (diff)
downloadgentoo-2-df72d1289d2eda0b4ef28293a8b66610ec4bc4a2.tar.gz
gentoo-2-df72d1289d2eda0b4ef28293a8b66610ec4bc4a2.tar.bz2
gentoo-2-df72d1289d2eda0b4ef28293a8b66610ec4bc4a2.zip
Correct usage of `python-config`. Fixes bug #247190.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/tclpython')
-rw-r--r--dev-tcltk/tclpython/ChangeLog10
-rw-r--r--dev-tcltk/tclpython/tclpython-4.1-r1.ebuild (renamed from dev-tcltk/tclpython/tclpython-4.1.ebuild)8
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-tcltk/tclpython/ChangeLog b/dev-tcltk/tclpython/ChangeLog
index f8996b316ba2..6929358a928f 100644
--- a/dev-tcltk/tclpython/ChangeLog
+++ b/dev-tcltk/tclpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/tclpython
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/ChangeLog,v 1.8 2007/02/22 01:33:03 peper Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/ChangeLog,v 1.9 2009/04/16 19:13:18 mescalinum Exp $
+
+*tclpython-4.1-r1 (16 Apr 2009)
+
+ 16 Apr 2009; Federico Ferri <mescalinum@gentoo.org>
+ +tclpython-4.1-r1.ebuild:
+ Correct usage of `python-config`. Fixes bug #247190.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-tcltk/tclpython/tclpython-4.1.ebuild b/dev-tcltk/tclpython/tclpython-4.1-r1.ebuild
index 1e2e4df20440..bb92b49bda0f 100644
--- a/dev-tcltk/tclpython/tclpython-4.1.ebuild
+++ b/dev-tcltk/tclpython/tclpython-4.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-4.1.ebuild,v 1.1 2006/05/03 16:36:57 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-4.1-r1.ebuild,v 1.1 2009/04/16 19:13:18 mescalinum Exp $
inherit distutils toolchain-funcs
@@ -18,7 +18,9 @@ DEPEND=">=dev-lang/tcl-8.0
src_compile() {
distutils_python_version
- $(tc-getCC) -shared -o tclpython.so.${PV} -fPIC ${CFLAGS} -Wall -I/usr/include/python${PYVER} tcl{python,thread}.c `python-config` -lpthread -lutil || die
+ $(tc-getCC) -shared -o tclpython.so.${PV} -fPIC ${CFLAGS} -Wall \
+ -I/usr/include/python${PYVER} tcl{python,thread}.c \
+ `python-config --libs` -lpthread -lutil || die
}
src_install() {