summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-01-29 17:56:36 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-01-29 17:56:36 +0000
commit9e19b241adef80a929d585f8eea8f29a02fe931a (patch)
tree9ff9bcf60d9f57572914cb32490a5cde29851cd6 /dev-scheme/gambit
parentfix for the new libdir patch (diff)
downloadgentoo-2-9e19b241adef80a929d585f8eea8f29a02fe931a.tar.gz
gentoo-2-9e19b241adef80a929d585f8eea8f29a02fe931a.tar.bz2
gentoo-2-9e19b241adef80a929d585f8eea8f29a02fe931a.zip
add gambit-4.0_beta20, bug 135551
(Portage version: 2.1.2-r5)
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/ChangeLog9
-rw-r--r--dev-scheme/gambit/files/digest-gambit-4.0_beta203
-rw-r--r--dev-scheme/gambit/gambit-4.0_beta20.ebuild90
3 files changed, 100 insertions, 2 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index 78720f31f4f4..feb14449d408 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/gambit
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.1 2005/10/17 04:09:47 mkennedy Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.2 2007/01/29 17:56:36 hkbst Exp $
+
+*gambit-4.0_beta20 (29 Jan 2007)
+
+ 29 Jan 2007; Marijn Schouten <hkBst@gentoo.org> +gambit-4.0_beta20.ebuild:
+ add beta20
*gambit-4.0_beta15 (17 Oct 2005)
diff --git a/dev-scheme/gambit/files/digest-gambit-4.0_beta20 b/dev-scheme/gambit/files/digest-gambit-4.0_beta20
new file mode 100644
index 000000000000..b64a19cedcd8
--- /dev/null
+++ b/dev-scheme/gambit/files/digest-gambit-4.0_beta20
@@ -0,0 +1,3 @@
+MD5 fb58e5bd67e52d88797672cbf04d34b3 gambc-4.0b20.tar.gz 7025146
+RMD160 450177391c220aac2569c56ff0dcc5201a7592a1 gambc-4.0b20.tar.gz 7025146
+SHA256 2ab46aead25b82b06d8f8dbe59b33896d32055f8340df2522ecfc11844ebb5a8 gambc-4.0b20.tar.gz 7025146
diff --git a/dev-scheme/gambit/gambit-4.0_beta20.ebuild b/dev-scheme/gambit/gambit-4.0_beta20.ebuild
new file mode 100644
index 000000000000..0b4122a0f81b
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.0_beta20.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0_beta20.ebuild,v 1.1 2007/01/29 17:56:36 hkbst Exp $
+
+inherit eutils elisp-common check-reqs autotools multilib
+
+MY_PN=gambc
+MY_PV=${PV//_beta/b}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/4.0/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="emacs? ( app-editors/emacs )"
+
+SITEFILE="50gambit-gentoo.el"
+
+S=${WORKDIR}/${MY_P}
+
+IUSE="emacs gcc-opts"
+
+pkg_setup() {
+ if ! use gcc-opts; then
+ ewarn "not using gcc specific optimizations"
+ ewarn "approximately 0.5GB ram will be needed"
+ ewarn "if you experience thrashing, try disabling parallel building"
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="768"check_reqs
+ else
+ ewarn "using gcc specific optimizations."
+ ewarn "this will cause approximately 2GB ram to be used instead of 0.5GB."
+ ewarn "this will probably cause heavy thrashing of your system."
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="2560" check_reqs
+ fi
+}
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+ sed "s/PACKAGE_SUBDIR=\"\/${MY_PV}\"/PACKAGE_SUBDIR=\"\/\"/" -i configure.ac
+ eautoreconf
+}
+
+src_compile() {
+ econf --enable-shared --enable-single-host $(use_enable gcc-opts)
+ emake || die "emake failed"
+
+ if use emacs; then
+ ( cd misc; elisp-comp *.el )
+ fi
+
+ einfo "compiling syntax-case.scm..."
+ LD_LIBRARY_PATH="lib/" GAMBCOPT="=." gsc/gsc misc/syntax-case.scm
+}
+
+src_install() {
+ einstall docdir=${D}/usr/share/doc/${PF} || die "einstall failed"
+
+ rm ${D}/usr/current
+
+ dolib syntax-case.*
+ mv ${D}/usr/syntax-case.scm ${D}/usr/$(get_libdir)
+
+ # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
+ mv ${D}/usr/bin/gsc ${D}/usr/bin/gsc-gambit
+
+ # remove emacs/site-lisp/gambit.el
+ rm -r ${D}/usr/share/emacs
+ if use emacs; then
+ elisp-install ${PN} misc/*.{el,elc}
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+
+ dodoc INSTALL.txt README
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+
+ # create some more explicit names
+ dosym gsc-gambit usr/bin/gambitsc
+ dosym gsi usr/bin/gambitsi
+
+ dodir /etc/env.d/ && echo "GAMBCOPT=\"=/usr/lib/\"" > ${D}/etc/env.d/50gambit
+ # automatically load syntax-case for r5rs goodness
+ echo '(load "~~syntax-case")' > ${D}/usr/lib/gambcext
+}