summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-10-31 07:08:13 +0000
committerHans de Graaff <graaff@gentoo.org>2014-10-31 07:08:13 +0000
commitea3b4801618229dbd4a6ff2742e99b8b6f2971cb (patch)
tree7f9e913ad7d07d00b023216a4a69af7d069365a3 /dev-ruby
parentPigeonhole version bump (diff)
downloadgentoo-2-ea3b4801618229dbd4a6ff2742e99b8b6f2971cb.tar.gz
gentoo-2-ea3b4801618229dbd4a6ff2742e99b8b6f2971cb.tar.bz2
gentoo-2-ea3b4801618229dbd4a6ff2742e99b8b6f2971cb.zip
Version bump for security issue CVE-2014-7819.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/sprockets/ChangeLog10
-rw-r--r--dev-ruby/sprockets/sprockets-2.1.4.ebuild49
-rw-r--r--dev-ruby/sprockets/sprockets-2.12.3.ebuild69
-rw-r--r--dev-ruby/sprockets/sprockets-2.2.3.ebuild63
4 files changed, 190 insertions, 1 deletions
diff --git a/dev-ruby/sprockets/ChangeLog b/dev-ruby/sprockets/ChangeLog
index a36b473eaa81..06da6bfdd82b 100644
--- a/dev-ruby/sprockets/ChangeLog
+++ b/dev-ruby/sprockets/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/sprockets
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sprockets/ChangeLog,v 1.27 2014/10/02 12:21:02 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sprockets/ChangeLog,v 1.28 2014/10/31 07:08:13 graaff Exp $
+
+*sprockets-2.12.3 (31 Oct 2014)
+*sprockets-2.2.3 (31 Oct 2014)
+*sprockets-2.1.4 (31 Oct 2014)
+
+ 31 Oct 2014; Hans de Graaff <graaff@gentoo.org> +sprockets-2.1.4.ebuild,
+ +sprockets-2.2.3.ebuild, +sprockets-2.12.3.ebuild:
+ Version bump for security issue CVE-2014-7819.
*sprockets-2.12.2 (02 Oct 2014)
diff --git a/dev-ruby/sprockets/sprockets-2.1.4.ebuild b/dev-ruby/sprockets/sprockets-2.1.4.ebuild
new file mode 100644
index 000000000000..d35f1e96c5a5
--- /dev/null
+++ b/dev-ruby/sprockets/sprockets-2.1.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sprockets/sprockets-2.1.4.ebuild,v 1.1 2014/10/31 07:08:13 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_GEMSPEC="sprockets.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Ruby library for compiling and serving web assets"
+HOMEPAGE="https://github.com/sstephenson/sprockets"
+SRC_URI="https://github.com/sstephenson/sprockets/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="sstephenson-sprockets-*"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/hike-1* >=dev-ruby/hike-1.2
+ =dev-ruby/rack-1*
+ >=dev-ruby/tilt-1.3.1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/json
+ dev-ruby/rack-test
+ =dev-ruby/coffee-script-2*
+ dev-ruby/execjs:1
+ )"
+
+all_ruby_prepare() {
+ # Avoid tests for template types that we currently don't package:
+ # eco and ejs.
+ sed -i -e '/eco templates/,/end/ s:^:#:' \
+ -e '/ejs templates/,/end/ s:^:#:' test/test_environment.rb || die
+
+ # Avoid failing tests. These no longer fail in upstream HEAD and we
+ # did not run tests before at all so its not a regression.
+ rm test/test_asset.rb test/test_server.rb || die
+
+ # Avoid test depending on specific execjs version
+ sed -i -e '/bundled asset cached if theres an error building it/askip "gentoo"' test/test_environment.rb || die
+}
diff --git a/dev-ruby/sprockets/sprockets-2.12.3.ebuild b/dev-ruby/sprockets/sprockets-2.12.3.ebuild
new file mode 100644
index 000000000000..b0186464c443
--- /dev/null
+++ b/dev-ruby/sprockets/sprockets-2.12.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sprockets/sprockets-2.12.3.ebuild,v 1.1 2014/10/31 07:08:13 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="sprockets.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Ruby library for compiling and serving web assets"
+HOMEPAGE="https://github.com/sstephenson/sprockets"
+SRC_URI="https://github.com/sstephenson/sprockets/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/hike-1* >=dev-ruby/hike-1.2
+ =dev-ruby/multi_json-1*
+ =dev-ruby/rack-1*
+ =dev-ruby/tilt-1* >=dev-ruby/tilt-1.3.1
+ !!<dev-ruby/sprockets-2.2.2-r1:2.2"
+
+ruby_add_bdepend "test? (
+ dev-ruby/json
+ dev-ruby/rack-test
+ =dev-ruby/coffee-script-2*
+ =dev-ruby/execjs-2*
+ =dev-ruby/sass-3* >=dev-ruby/sass-3.1
+ )"
+
+all_ruby_prepare() {
+ # Avoid tests for template types that we currently don't package:
+ # eco and ejs.
+ sed -i -e '/eco templates/,/end/ s:^:#:' \
+ -e '/ejs templates/,/end/ s:^:#:' test/test_environment.rb || die
+
+ # Add missing 'json' require
+ sed -i -e '4irequire "json"' test/test_manifest.rb || die
+
+ # Avoid test breaking on specific javascript error being thrown,
+ # most likely due to using node instead of v8.
+ sed -i -e '/bundled asset cached if theres an error/,/^ end/ s:^:#:' test/test_environment.rb || die
+
+ # Require a newer version of execjs since we do not have this slotted.
+ sed -i -e '/execjs/ s/1.0/2.0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_prepare() {
+ sed -i -e "s:ruby:${RUBY}:" test/test_sprocketize.rb || die
+}
+
+each_ruby_test() {
+ # Make sure we have completely separate copies. Hardlinks won't work
+ # for this test suite.
+ cp -R test test-new || die
+ rm -rf test || die
+ mv test-new test || die
+
+ each_fakegem_test
+}
diff --git a/dev-ruby/sprockets/sprockets-2.2.3.ebuild b/dev-ruby/sprockets/sprockets-2.2.3.ebuild
new file mode 100644
index 000000000000..b4037b0df07b
--- /dev/null
+++ b/dev-ruby/sprockets/sprockets-2.2.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sprockets/sprockets-2.2.3.ebuild,v 1.1 2014/10/31 07:08:13 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_GEMSPEC="sprockets.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Ruby library for compiling and serving web assets"
+HOMEPAGE="https://github.com/sstephenson/sprockets"
+SRC_URI="https://github.com/sstephenson/sprockets/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/hike-1.2:0
+ =dev-ruby/multi_json-1*
+ =dev-ruby/rack-1*
+ =dev-ruby/tilt-1* >=dev-ruby/tilt-1.3.1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/json
+ dev-ruby/rack-test
+ =dev-ruby/coffee-script-2*
+ dev-ruby/execjs:1
+ )"
+
+all_ruby_prepare() {
+ # Avoid tests for template types that we currently don't package:
+ # eco and ejs.
+ sed -i -e '/eco templates/,/end/ s:^:#:' \
+ -e '/ejs templates/,/end/ s:^:#:' test/test_environment.rb || die
+
+ # Avoid failing tests. These no longer fail in upstream HEAD and we
+ # did not run tests before at all so its not a regression.
+ rm test/test_asset.rb test/test_server.rb || die
+
+ # Ignore failing tests with sprockets 2.2.1. These pass with the
+ # latest versions but we need to put in this old version to support
+ # Rails 3.2.9.
+ sed -i -e '/depedencies are cached/,/end/ s:^:#:' test/test_caching.rb || die
+ sed -i -e '/remove old asset/,/^ end/ s:^:#:' test/test_manifest.rb || die
+
+ # Fix missing json include
+ sed -i -e '5irequire "json"' test/sprockets_test.rb || die
+
+ # Avoid test depending on specific execjs version
+ sed -i -e '/bundled asset cached if theres an error building it/askip "gentoo"' test/test_environment.rb || die
+
+ # Avoid test failing due to encoding specifics and available locales.
+ sed -i -e '/read ASCII asset/askip "gentoo"' test/test_encoding.rb || die
+}