summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-05 05:47:12 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-05 05:47:12 +0000
commit511a79be6f1d883be0f34dd5db6f68e2a60df14c (patch)
treec38032c4c197480bf1603089df1bfcbd3380eef5 /dev-ruby
parentdrop py2.6 add pypy support (diff)
downloadgentoo-2-511a79be6f1d883be0f34dd5db6f68e2a60df14c.tar.gz
gentoo-2-511a79be6f1d883be0f34dd5db6f68e2a60df14c.tar.bz2
gentoo-2-511a79be6f1d883be0f34dd5db6f68e2a60df14c.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/addressable/ChangeLog9
-rw-r--r--dev-ruby/addressable/addressable-2.3.6.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-ruby/addressable/ChangeLog b/dev-ruby/addressable/ChangeLog
index a3dcce55fce5..2f37b2ca1279 100644
--- a/dev-ruby/addressable/ChangeLog
+++ b/dev-ruby/addressable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/addressable
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.39 2013/12/22 18:45:01 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.40 2014/05/05 05:47:12 graaff Exp $
+
+*addressable-2.3.6 (05 May 2014)
+
+ 05 May 2014; Hans de Graaff <graaff@gentoo.org> +addressable-2.3.6.ebuild:
+ Version bump.
22 Dec 2013; Anthony G. Basile <blueness@gentoo.org>
addressable-2.3.5-r1.ebuild:
diff --git a/dev-ruby/addressable/addressable-2.3.6.ebuild b/dev-ruby/addressable/addressable-2.3.6.ebuild
new file mode 100644
index 000000000000..6e33abd3d342
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.3.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/addressable-2.3.6.ebuild,v 1.1 2014/05/05 05:47:12 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library."
+HOMEPAGE="http://addressable.rubyforge.org/"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm tasks/rspec.rake || die
+ sed -i -e '/[Cc]overalls/d' spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm spec/addressable/net_http_compat_spec.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Remove specs with ruby19-syntax.
+ rm spec/addressable/template_spec.rb || die
+ ;;
+ esac
+}