summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-11-02 18:35:39 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-11-02 18:35:39 +0000
commit2c255ba3a5fc165bede50ecb2750df829fc62a1c (patch)
tree3d91bc7b21ea6e6ca879ee7b6f2f477c1b5cf46e /dev-ruby
parentadd ebuild for oslo-i18n (diff)
downloadgentoo-2-2c255ba3a5fc165bede50ecb2750df829fc62a1c.tar.gz
gentoo-2-2c255ba3a5fc165bede50ecb2750df829fc62a1c.tar.bz2
gentoo-2-2c255ba3a5fc165bede50ecb2750df829fc62a1c.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/sqlite3/ChangeLog8
-rw-r--r--dev-ruby/sqlite3/sqlite3-1.3.10.ebuild (renamed from dev-ruby/sqlite3/sqlite3-1.3.8-r1.ebuild)14
2 files changed, 17 insertions, 5 deletions
diff --git a/dev-ruby/sqlite3/ChangeLog b/dev-ruby/sqlite3/ChangeLog
index 02ebe4a69ecc..29b537d8a2f3 100644
--- a/dev-ruby/sqlite3/ChangeLog
+++ b/dev-ruby/sqlite3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/sqlite3
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/ChangeLog,v 1.20 2014/08/13 18:50:24 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/ChangeLog,v 1.21 2014/11/02 18:35:39 mrueg Exp $
+
+*sqlite3-1.3.10 (02 Nov 2014)
+
+ 02 Nov 2014; Manuel Rüger <mrueg@gentoo.org> +sqlite3-1.3.10.ebuild,
+ -sqlite3-1.3.8-r1.ebuild:
+ Version bump.
13 Aug 2014; Raúl Porcel <armin76@gentoo.org> sqlite3-1.3.9-r1.ebuild:
Add ~sparc wrt #468536
diff --git a/dev-ruby/sqlite3/sqlite3-1.3.8-r1.ebuild b/dev-ruby/sqlite3/sqlite3-1.3.10.ebuild
index 54ec15477b6e..15154cf97e78 100644
--- a/dev-ruby/sqlite3/sqlite3-1.3.8-r1.ebuild
+++ b/dev-ruby/sqlite3/sqlite3-1.3.10.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/sqlite3-1.3.8-r1.ebuild,v 1.5 2014/04/05 14:36:48 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/sqlite3-1.3.10.ebuild,v 1.1 2014/11/02 18:35:39 mrueg Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20"
+USE_RUBY="ruby19 ruby20 ruby21"
-RUBY_FAKEGEM_TASK_DOC="docs faq"
+RUBY_FAKEGEM_TASK_DOC="faq"
RUBY_FAKEGEM_DOCDIR="doc faq"
RUBY_FAKEGEM_EXTRADOC="API_CHANGES.rdoc README.rdoc ChangeLog.cvs CHANGELOG.rdoc"
@@ -44,6 +44,12 @@ each_ruby_configure() {
${RUBY} -Cext/sqlite3 extconf.rb || die
}
+all_ruby_compile() {
+ all_fakegem_compile
+
+ rdoc --title "${P} Dcoumentation" -o doc --main README.rdoc lib *.rdoc ext/*/*.c || die
+}
+
each_ruby_compile() {
# TODO: not sure what happens with jruby
@@ -60,7 +66,7 @@ each_ruby_install() {
# sqlite3` was already part of sqlite3-ruby requirements.
cat - <<EOF > "${T}/sqlite3-ruby.gemspec"
# generated by ebuild
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/sqlite3-1.3.8-r1.ebuild,v 1.5 2014/04/05 14:36:48 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/sqlite3-1.3.10.ebuild,v 1.1 2014/11/02 18:35:39 mrueg Exp $
Gem::Specification.new do |s|
s.name = "sqlite3-ruby"
s.version = "${RUBY_FAKEGEM_VERSION}"