summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-02 09:30:44 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-02 09:30:44 +0000
commit073c17d915b75cd03c253bfca231ebf165337f1a (patch)
treef972c894a5cc0d1508fc8412d4ac477f14e60b7b /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-073c17d915b75cd03c253bfca231ebf165337f1a.tar.gz
gentoo-2-073c17d915b75cd03c253bfca231ebf165337f1a.tar.bz2
gentoo-2-073c17d915b75cd03c253bfca231ebf165337f1a.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-inline/ChangeLog7
-rw-r--r--dev-ruby/ruby-inline/ruby-inline-3.8.6.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/ruby-inline/ChangeLog b/dev-ruby/ruby-inline/ChangeLog
index ad1f16727d97..16fb22ba29fe 100644
--- a/dev-ruby/ruby-inline/ChangeLog
+++ b/dev-ruby/ruby-inline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-inline
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ChangeLog,v 1.26 2010/08/28 13:15:41 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ChangeLog,v 1.27 2010/10/02 09:30:44 graaff Exp $
+
+*ruby-inline-3.8.6 (02 Oct 2010)
+
+ 02 Oct 2010; Hans de Graaff <graaff@gentoo.org> +ruby-inline-3.8.6.ebuild:
+ Version bump.
*ruby-inline-3.8.4-r2 (28 Aug 2010)
diff --git a/dev-ruby/ruby-inline/ruby-inline-3.8.6.ebuild b/dev-ruby/ruby-inline/ruby-inline-3.8.6.ebuild
new file mode 100644
index 000000000000..5778100bff7e
--- /dev/null
+++ b/dev-ruby/ruby-inline/ruby-inline-3.8.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ruby-inline-3.8.6.ebuild,v 1.1 2010/10/02 09:30:44 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="RubyInline"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend dev-ruby/zentest
+
+ruby_add_bdepend "
+ doc? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ )
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # we have to patch the code so that it takes the RUBY_DESCRIPTION
+ # into consideration, to avoid loading Ruby-Enterprise (REE18)
+ # objects in MRI and vice-versa; we're a bit “greedier” since we
+ # will rebuild objects even when just switching versions, but
+ # it'll be better this way than being too conservatives.
+ epatch "${FILESDIR}/${PN}-3.8.4-gentoo.patch"
+
+ # Respect ruby's (and thus Gentoo's) LDFLAGS, and explicitly link
+ # against the ruby shared library to avoid confusion and potential
+ # crashes when later using the shared object.
+ epatch "${FILESDIR}/${PN}-3.8.4-ldflags.patch"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb || die
+}