summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-02-14 02:38:46 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-02-14 02:38:46 +0000
commit06eaba8613c5b5261778ea341435fa765ee0113a (patch)
tree7ff08fdc1a40357ade055d08ce5f9f691b29c9b1 /dev-ruby
parentVersion bump. Remove old. (diff)
downloadgentoo-2-06eaba8613c5b5261778ea341435fa765ee0113a.tar.gz
gentoo-2-06eaba8613c5b5261778ea341435fa765ee0113a.tar.bz2
gentoo-2-06eaba8613c5b5261778ea341435fa765ee0113a.zip
Version bump. Remove old.e
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/msgpack/ChangeLog8
-rw-r--r--dev-ruby/msgpack/msgpack-0.5.11.ebuild (renamed from dev-ruby/msgpack/msgpack-0.5.8.ebuild)10
-rw-r--r--dev-ruby/msgpack/msgpack-0.5.9.ebuild36
3 files changed, 13 insertions, 41 deletions
diff --git a/dev-ruby/msgpack/ChangeLog b/dev-ruby/msgpack/ChangeLog
index d9c067e0946d..a71f16bb902b 100644
--- a/dev-ruby/msgpack/ChangeLog
+++ b/dev-ruby/msgpack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/msgpack
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/ChangeLog,v 1.28 2015/01/21 07:13:22 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/ChangeLog,v 1.29 2015/02/14 02:38:46 mrueg Exp $
+
+*msgpack-0.5.11 (14 Feb 2015)
+
+ 14 Feb 2015; Manuel Rüger <mrueg@gentoo.org> +msgpack-0.5.11.ebuild,
+ -msgpack-0.5.8.ebuild, -msgpack-0.5.9.ebuild:
+ Version bump. Remove old.e
*msgpack-0.5.10 (21 Jan 2015)
diff --git a/dev-ruby/msgpack/msgpack-0.5.8.ebuild b/dev-ruby/msgpack/msgpack-0.5.11.ebuild
index 8a381def7bac..bdec57bdbe1d 100644
--- a/dev-ruby/msgpack/msgpack-0.5.8.ebuild
+++ b/dev-ruby/msgpack/msgpack-0.5.11.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/msgpack-0.5.8.ebuild,v 1.2 2014/08/02 01:41:00 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/msgpack-0.5.11.ebuild,v 1.1 2015/02/14 02:38:46 mrueg Exp $
EAPI=5
-# jruby → uses a binary extension
USE_RUBY="ruby19 ruby20 ruby21"
RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRADOC="README.rdoc"
inherit multilib ruby-fakegem
@@ -25,6 +24,9 @@ ruby_add_bdepend "doc? ( dev-ruby/yard )"
all_ruby_prepare() {
sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove jruby-specific specs that are run also for other rubies.
+ rm -rf spec/jruby || die
}
each_ruby_configure() {
diff --git a/dev-ruby/msgpack/msgpack-0.5.9.ebuild b/dev-ruby/msgpack/msgpack-0.5.9.ebuild
deleted file mode 100644
index df9686eb417f..000000000000
--- a/dev-ruby/msgpack/msgpack-0.5.9.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/msgpack-0.5.9.ebuild,v 1.1 2014/10/17 06:04:02 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
-HOMEPAGE="http://msgpack.sourceforge.jp/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="doc"
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/${PN}
- cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
-}