summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-21 07:09:01 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-21 07:09:01 +0000
commit9ed212a81bea2e76735ba638bb518323f62533d3 (patch)
treead534d576348f0b901d35ab4450bdfc8050a3ed7 /dev-ruby/xpath
parentReinstate quoting, as it apparently fails. (diff)
downloadgentoo-2-9ed212a81bea2e76735ba638bb518323f62533d3.tar.gz
gentoo-2-9ed212a81bea2e76735ba638bb518323f62533d3.tar.bz2
gentoo-2-9ed212a81bea2e76735ba638bb518323f62533d3.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/xpath')
-rw-r--r--dev-ruby/xpath/ChangeLog7
-rw-r--r--dev-ruby/xpath/xpath-1.0.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-ruby/xpath/ChangeLog b/dev-ruby/xpath/ChangeLog
index 4765ff9815b3..2b34ccbebc36 100644
--- a/dev-ruby/xpath/ChangeLog
+++ b/dev-ruby/xpath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/xpath
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xpath/ChangeLog,v 1.5 2012/07/05 21:53:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xpath/ChangeLog,v 1.6 2012/11/21 07:09:01 graaff Exp $
+
+*xpath-1.0.0 (21 Nov 2012)
+
+ 21 Nov 2012; Hans de Graaff <graaff@gentoo.org> +xpath-1.0.0.ebuild:
+ Version bump.
05 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> xpath-0.1.4.ebuild:
Use the new rspec testing support; remove jruby from the compatible
diff --git a/dev-ruby/xpath/xpath-1.0.0.ebuild b/dev-ruby/xpath/xpath-1.0.0.ebuild
new file mode 100644
index 000000000000..e757db44898a
--- /dev/null
+++ b/dev-ruby/xpath/xpath-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xpath/xpath-1.0.0.ebuild,v 1.1 2012/11/21 07:09:01 graaff Exp $
+
+EAPI="4"
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="XPath is a Ruby DSL around a subset of XPath 1.0."
+HOMEPAGE="https://github.com/jnicklas/xpath"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="1"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' spec/spec_helper.rb || die
+}