summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-02-21 05:07:46 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-02-21 05:07:46 +0000
commit1074b507522fde032da164ee5194795ccfdcaa6d (patch)
tree5a2cba450b4cfec80949bde5d8fdfdd9b2a20d3d /dev-ruby/xml-simple
parentVersion bump. (diff)
downloadgentoo-2-1074b507522fde032da164ee5194795ccfdcaa6d.tar.gz
gentoo-2-1074b507522fde032da164ee5194795ccfdcaa6d.tar.bz2
gentoo-2-1074b507522fde032da164ee5194795ccfdcaa6d.zip
Version bump. Run tests. Add ruby22.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/xml-simple')
-rw-r--r--dev-ruby/xml-simple/ChangeLog9
-rw-r--r--dev-ruby/xml-simple/xml-simple-1.1.5.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-ruby/xml-simple/ChangeLog b/dev-ruby/xml-simple/ChangeLog
index da7eebd89b73..9d52d41c0ff6 100644
--- a/dev-ruby/xml-simple/ChangeLog
+++ b/dev-ruby/xml-simple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/xml-simple
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xml-simple/ChangeLog,v 1.45 2014/10/29 18:50:50 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xml-simple/ChangeLog,v 1.46 2015/02/21 05:07:46 mrueg Exp $
+
+*xml-simple-1.1.5 (21 Feb 2015)
+
+ 21 Feb 2015; Manuel Rüger <mrueg@gentoo.org> +xml-simple-1.1.5.ebuild:
+ Version bump. Run tests. Add ruby22.
29 Oct 2014; Manuel Rüger <mrueg@gentoo.org> xml-simple-1.1.3.ebuild,
xml-simple-1.1.4.ebuild:
diff --git a/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild b/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild
new file mode 100644
index 000000000000..2cbbd05111f5
--- /dev/null
+++ b/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild,v 1.1 2015/02/21 05:07:46 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+# Gem only contains lib code, and github repository has no tags.
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/maik/xml-simple/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Easy API to maintain XML. It is a Ruby port of Grant McLean's Perl module XML::Simple"
+HOMEPAGE="https://github.com/maik/xml-simple"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+each_ruby_test() {
+ cd test || die
+ for i in *.rb; do
+ ${RUBY} -I../lib ${i} || die
+ done
+}