summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-03 06:47:20 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-03 06:47:20 +0000
commit0d4c1e8bffc942a75687bf95858b4ac1bea88bec (patch)
tree7c1186918589de2d2738d7472ee8d9c521b57fe2 /dev-ruby/unf_ext
parentBump (diff)
downloadgentoo-2-0d4c1e8bffc942a75687bf95858b4ac1bea88bec.tar.gz
gentoo-2-0d4c1e8bffc942a75687bf95858b4ac1bea88bec.tar.bz2
gentoo-2-0d4c1e8bffc942a75687bf95858b4ac1bea88bec.zip
Add ruby21.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/unf_ext')
-rw-r--r--dev-ruby/unf_ext/ChangeLog7
-rw-r--r--dev-ruby/unf_ext/unf_ext-0.0.6-r2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-ruby/unf_ext/ChangeLog b/dev-ruby/unf_ext/ChangeLog
index 02e35ca5a420..18dfdeb5a93a 100644
--- a/dev-ruby/unf_ext/ChangeLog
+++ b/dev-ruby/unf_ext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/unf_ext
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf_ext/ChangeLog,v 1.14 2014/04/12 23:53:59 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf_ext/ChangeLog,v 1.15 2014/05/03 06:47:20 graaff Exp $
+
+*unf_ext-0.0.6-r2 (03 May 2014)
+
+ 03 May 2014; Hans de Graaff <graaff@gentoo.org> +unf_ext-0.0.6-r2.ebuild:
+ Add ruby21.
12 Apr 2014; Manuel Rüger <mrueg@gentoo.org> unf_ext-0.0.6-r1.ebuild,
unf_ext-0.0.6.ebuild:
diff --git a/dev-ruby/unf_ext/unf_ext-0.0.6-r2.ebuild b/dev-ruby/unf_ext/unf_ext-0.0.6-r2.ebuild
new file mode 100644
index 000000000000..e7790b3246bc
--- /dev/null
+++ b/dev-ruby/unf_ext/unf_ext-0.0.6-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf_ext/unf_ext-0.0.6-r2.ebuild,v 1.1 2014/05/03 06:47:20 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem multilib
+
+DESCRIPTION="Unicode Normalization Form support library for CRuby"
+HOMEPAGE="http://sourceforge.jp/projects/unf/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ dev-ruby/shoulda
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/ s:^:#:' Rakefile test/helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/unf_ext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/unf_ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/unf_ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}