summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-04 07:05:35 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-04 07:05:35 +0000
commite86f716ff145af9a3e80f627381a026cf17632cd (patch)
tree3746f13b277f93d8c995dd33611d11ecbf5e4b35 /dev-ruby/timecop
parentVersion bump. (diff)
downloadgentoo-2-e86f716ff145af9a3e80f627381a026cf17632cd.tar.gz
gentoo-2-e86f716ff145af9a3e80f627381a026cf17632cd.tar.bz2
gentoo-2-e86f716ff145af9a3e80f627381a026cf17632cd.zip
Version bump. Drop jruby since the code is no longer compatible.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/timecop')
-rw-r--r--dev-ruby/timecop/ChangeLog7
-rw-r--r--dev-ruby/timecop/timecop-0.7.1.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/timecop/ChangeLog b/dev-ruby/timecop/ChangeLog
index 27d6f979591f..0397a7f141bb 100644
--- a/dev-ruby/timecop/ChangeLog
+++ b/dev-ruby/timecop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/timecop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/timecop/ChangeLog,v 1.16 2014/04/24 16:49:12 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/timecop/ChangeLog,v 1.17 2014/05/04 07:05:35 graaff Exp $
+
+*timecop-0.7.1 (04 May 2014)
+
+ 04 May 2014; Hans de Graaff <graaff@gentoo.org> +timecop-0.7.1.ebuild:
+ Version bump. Drop jruby since the code is no longer compatible.
24 Apr 2014; Manuel Rüger <mrueg@gentoo.org> timecop-0.6.0.ebuild:
Remove ruby18 support.
diff --git a/dev-ruby/timecop/timecop-0.7.1.ebuild b/dev-ruby/timecop/timecop-0.7.1.ebuild
new file mode 100644
index 000000000000..f8e51dd71d9b
--- /dev/null
+++ b/dev-ruby/timecop/timecop-0.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/timecop/timecop-0.7.1.ebuild,v 1.1 2014/05/04 07:05:35 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
+HOMEPAGE="http://github.com/jtrupiano/timecop"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' -e '/History.rdoc/d' Rakefile test/test_helper.rb || die
+ sed -i -e '/rubygems/ a\gem "test-unit"' test/test_helper.rb || die
+}
+each_ruby_prepare() {
+ sed -i -e "/bin\/sh/ a\RUBY='${RUBY}'" test/run_tests.sh || die
+}