summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-11 17:33:30 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-11 17:33:30 +0000
commit38005e833cc04454d1a70f3055c42a8da77bea97 (patch)
tree163d134316f6a0e30c037e55616633bf9c1a5383 /dev-ruby/test-unit
parentFix gettext regeneration issue (bug #420365) and fix build with glib-2.32. (diff)
downloadgentoo-2-38005e833cc04454d1a70f3055c42a8da77bea97.tar.gz
gentoo-2-38005e833cc04454d1a70f3055c42a8da77bea97.tar.bz2
gentoo-2-38005e833cc04454d1a70f3055c42a8da77bea97.zip
Drop USE=doc from this version to facilitate bootstrapping a stable tree for ruby19.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog6
-rw-r--r--dev-ruby/test-unit/test-unit-2.4.8.ebuild17
2 files changed, 7 insertions, 16 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 7113de275aa4..5601203fa1a7 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.54 2012/06/10 05:59:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.55 2012/06/11 17:33:30 graaff Exp $
+
+ 11 Jun 2012; Hans de Graaff <graaff@gentoo.org> test-unit-2.4.8.ebuild:
+ Drop USE=doc from this version to facilitate bootstrapping a stable tree for
+ ruby19.
*test-unit-2.5.0 (10 Jun 2012)
diff --git a/dev-ruby/test-unit/test-unit-2.4.8.ebuild b/dev-ruby/test-unit/test-unit-2.4.8.ebuild
index 91e3564f59c6..66bb8dd7a798 100644
--- a/dev-ruby/test-unit/test-unit-2.4.8.ebuild
+++ b/dev-ruby/test-unit/test-unit-2.4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.4.8.ebuild,v 1.1 2012/03/07 06:55:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.4.8.ebuild,v 1.2 2012/06/11 17:33:30 graaff Exp $
EAPI=2
USE_RUBY="ruby18 ruby19 ree18 jruby"
@@ -14,29 +14,16 @@ RUBY_FAKEGEM_BINWRAP=""
inherit ruby-fakegem
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-# redcloth is also needed to build documentation, but not available for
-# jruby. Since we build documentation with the main ruby implementation
-# only we skip the dependency for jruby in this roundabout way, assuming
-# that jruby won't be the main ruby.
-USE_RUBY=ruby18 ruby_add_bdepend "ruby_targets_ruby18 doc" "( dev-ruby/redcloth )"
-USE_RUBY=ruby19 ruby_add_bdepend "ruby_targets_ruby19 doc" "( dev-ruby/redcloth )"
-USE_RUBY=ree18 ruby_add_bdepend "ruby_targets_ree18 doc" "( dev-ruby/redcloth )"
-
DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
HOMEPAGE="http://test-unit.rubyforge.org/"
LICENSE="Ruby"
SLOT="2"
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
+IUSE="test"
all_ruby_compile() {
all_fakegem_compile
-
- if use doc; then
- yard doc --title ${PN} || die
- fi
}
each_ruby_test() {