summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-15 18:53:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-15 18:53:45 +0000
commit21c0def1d23cb8ea2b826535299b520a3afd06f9 (patch)
treef5e2c1c27f9ab627be88d79ff5b5edf8c48775e5 /dev-ruby/test-unit
parentalpha/ia64/s390 stable wrt #295348 (diff)
downloadgentoo-2-21c0def1d23cb8ea2b826535299b520a3afd06f9.tar.gz
gentoo-2-21c0def1d23cb8ea2b826535299b520a3afd06f9.tar.bz2
gentoo-2-21c0def1d23cb8ea2b826535299b520a3afd06f9.zip
Bump to 2.0.5 and fakegem.
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog8
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.5.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index a34bd9c33ee5..cb002c10f744 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.10 2009/10/31 21:42:00 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.11 2009/12/15 18:53:45 flameeyes Exp $
+
+*test-unit-2.0.5 (15 Dec 2009)
+
+ 15 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +test-unit-2.0.5.ebuild:
+ Bump to 2.0.5 and fakegem.
31 Oct 2009; Mounir Lamouri <volkmar@gentoo.org>
test-unit-2.0.2-r1.ebuild, test-unit-2.0.3.ebuild:
diff --git a/dev-ruby/test-unit/test-unit-2.0.5.ebuild b/dev-ruby/test-unit/test-unit-2.0.5.ebuild
new file mode 100644
index 000000000000..43282f4dc66b
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.5.ebuild,v 1.1 2009/12/15 18:53:45 flameeyes Exp $
+
+EAPI=2
+# One test fails on jruby, might be a jruby bug
+USE_RUBY="ruby18 ruby19"
+
+# Don't enable docs yet since this requires hoe
+RUBY_FAKEGEM_TASK_DOC="" # doc
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.txt History.txt"
+
+inherit ruby-fakegem
+
+#ruby_add_bdepend doc dev-ruby/hoe
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}