summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-01 10:41:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-01 10:41:40 +0000
commit80d09aef8b6521772777cf674e785d84e7bc2898 (patch)
tree5501295957c609cdec7882f7cda9e38e14c0b763 /dev-ruby/test-spec
parentdev-lang/ruby:1.9 no longer provides rubygems (diff)
downloadgentoo-2-80d09aef8b6521772777cf674e785d84e7bc2898.tar.gz
gentoo-2-80d09aef8b6521772777cf674e785d84e7bc2898.tar.bz2
gentoo-2-80d09aef8b6521772777cf674e785d84e7bc2898.zip
Don't depend on test-unit-2 at runtime.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-spec')
-rw-r--r--dev-ruby/test-spec/ChangeLog6
-rw-r--r--dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild10
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-ruby/test-spec/ChangeLog b/dev-ruby/test-spec/ChangeLog
index 73580cda1672..95562b6c7e58 100644
--- a/dev-ruby/test-spec/ChangeLog
+++ b/dev-ruby/test-spec/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/test-spec
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/ChangeLog,v 1.14 2010/04/26 17:56:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/ChangeLog,v 1.15 2010/05/01 10:41:40 flameeyes Exp $
+
+ 01 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ test-spec-0.10.0-r2.ebuild:
+ Don't depend on test-unit-2 at runtime.
26 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org>
test-spec-0.10.0-r2.ebuild:
diff --git a/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild b/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild
index 77c98fed71d0..94c2680b4afa 100644
--- a/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild
+++ b/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild,v 1.8 2010/04/26 17:56:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild,v 1.9 2010/05/01 10:41:40 flameeyes Exp $
EAPI="2"
@@ -21,10 +21,14 @@ KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
ruby_add_rdepend virtual/ruby-test-unit
-USE_RUBY=ruby19 \
- ruby_add_rdepend ruby_targets_ruby19 '>=dev-ruby/test-unit-2.0.6'
ruby_add_bdepend test dev-ruby/mocha
+# On Ruby 1.9, the tests only work with test-unit-2, but generally
+# speaking, test-spec should work fine with test-unit-1.2.3, and
+# indeed some testsuites only work with that.
+USE_RUBY=ruby19 \
+ ruby_add_bdepend "ruby_targets_ruby19 test" '>=dev-ruby/test-unit-2.0.6'
+
all_ruby_prepare() {
epatch "${FILESDIR}"/${P}-jruby.patch
}