summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 16:00:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 16:00:41 +0000
commitbec0bea05493b792b01e89530328a3e5de66ec37 (patch)
tree8de86c26dc4ff4ab18f68c6179df67c80a35206a /dev-ruby/syntax
parentAdd ~alpha/~ia64/~sparc wrt #313563 (diff)
downloadgentoo-2-bec0bea05493b792b01e89530328a3e5de66ec37.tar.gz
gentoo-2-bec0bea05493b792b01e89530328a3e5de66ec37.tar.bz2
gentoo-2-bec0bea05493b792b01e89530328a3e5de66ec37.zip
Various cleanups.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/syntax')
-rw-r--r--dev-ruby/syntax/ChangeLog8
-rw-r--r--dev-ruby/syntax/syntax-1.0.0-r1.ebuild6
-rw-r--r--dev-ruby/syntax/syntax-1.0.0.ebuild6
3 files changed, 12 insertions, 8 deletions
diff --git a/dev-ruby/syntax/ChangeLog b/dev-ruby/syntax/ChangeLog
index b3cce5ebebae..19479401f37a 100644
--- a/dev-ruby/syntax/ChangeLog
+++ b/dev-ruby/syntax/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/syntax
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syntax/ChangeLog,v 1.20 2009/12/23 12:28:51 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syntax/ChangeLog,v 1.21 2010/05/22 16:00:41 flameeyes Exp $
+
+ 22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> syntax-1.0.0.ebuild,
+ syntax-1.0.0-r1.ebuild:
+ Various cleanups.
23 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
syntax-1.0.0-r1.ebuild:
diff --git a/dev-ruby/syntax/syntax-1.0.0-r1.ebuild b/dev-ruby/syntax/syntax-1.0.0-r1.ebuild
index 28c1abe331a8..1eb5d58bcf54 100644
--- a/dev-ruby/syntax/syntax-1.0.0-r1.ebuild
+++ b/dev-ruby/syntax/syntax-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syntax/syntax-1.0.0-r1.ebuild,v 1.2 2009/12/23 12:28:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syntax/syntax-1.0.0-r1.ebuild,v 1.3 2010/05/22 16:00:41 flameeyes Exp $
EAPI=2
@@ -22,7 +22,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="test"
-ruby_add_bdepend test virtual/ruby-test-unit
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
each_ruby_test() {
${RUBY} -Ilib test/ALL-TESTS.rb || die "tests failed"
diff --git a/dev-ruby/syntax/syntax-1.0.0.ebuild b/dev-ruby/syntax/syntax-1.0.0.ebuild
index 2ce8eaaae089..5d1f5057937b 100644
--- a/dev-ruby/syntax/syntax-1.0.0.ebuild
+++ b/dev-ruby/syntax/syntax-1.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syntax/syntax-1.0.0.ebuild,v 1.14 2009/07/06 21:08:36 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syntax/syntax-1.0.0.ebuild,v 1.15 2010/05/22 16:00:41 flameeyes Exp $
inherit ruby gems
@@ -12,4 +12,4 @@ SLOT="0"
KEYWORDS="~alpha amd64 hppa ia64 ~mips ppc ppc64 ~sparc x86"
IUSE=""
-USE_RUBY="ruby18 ruby19"
+USE_RUBY="ruby18"