summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-12-23 01:27:10 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-12-23 01:27:10 +0000
commit816f762efc8ee1cec091aebba811f92d0c0a0eae (patch)
tree176168228346f527073c3918ab06ad3d9673f074 /dev-ruby/rubygems
parentKeyword ~ppc64 now that mikmod works. (diff)
downloadgentoo-2-816f762efc8ee1cec091aebba811f92d0c0a0eae.tar.gz
gentoo-2-816f762efc8ee1cec091aebba811f92d0c0a0eae.tar.bz2
gentoo-2-816f762efc8ee1cec091aebba811f92d0c0a0eae.zip
Unset RUBYOPT before installing rubygems to prevent ruby from failing due to missing auto_gem (bug #158455)
(Portage version: 2.1.1)
Diffstat (limited to 'dev-ruby/rubygems')
-rw-r--r--dev-ruby/rubygems/ChangeLog7
-rw-r--r--dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild4
-rw-r--r--dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild8
3 files changed, 16 insertions, 3 deletions
diff --git a/dev-ruby/rubygems/ChangeLog b/dev-ruby/rubygems/ChangeLog
index 47a5a59c4100..8839695c1e1d 100644
--- a/dev-ruby/rubygems/ChangeLog
+++ b/dev-ruby/rubygems/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rubygems
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/ChangeLog,v 1.38 2006/12/16 14:40:47 pclouds Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/ChangeLog,v 1.39 2006/12/23 01:27:10 pclouds Exp $
+
+ 23 Dec 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
+ rubygems-0.9.0-r2.ebuild, rubygems-0.8.11-r5.ebuild:
+ Unset RUBYOPT before installing rubygems to prevent ruby from failing due to
+ missing auto_gem (bug #158455). Also warn people when rubygems is removed
*rubygems-0.9.0-r2 (16 Dec 2006)
diff --git a/dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild b/dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild
index 8c63103432ab..45251cb3e731 100644
--- a/dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild
+++ b/dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild,v 1.7 2006/04/30 16:19:15 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild,v 1.8 2006/12/23 01:27:10 pclouds Exp $
inherit ruby
@@ -25,6 +25,8 @@ src_compile() {
}
src_install() {
+ # RUBYOPT=-rauto_gem without rubygems installed will cause ruby to fail, bug #158455
+ unset RUBYOPT
ver=$(${RUBY} -r rbconfig -e 'print Config::CONFIG["MAJOR"] + "." + Config::CONFIG["MINOR"]')
GEM_HOME=${D}/usr/lib/ruby/gems/$ver ruby_src_install
cp ${FILESDIR}/auto_gem.rb ${D}/$(${RUBY} -r rbconfig -e 'print Config::CONFIG["sitedir"]')
diff --git a/dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild b/dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild
index 4ee10acf02bf..c2567d9f1c5d 100644
--- a/dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild
+++ b/dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild,v 1.1 2006/12/16 14:40:47 pclouds Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/rubygems-0.9.0-r2.ebuild,v 1.2 2006/12/23 01:27:10 pclouds Exp $
inherit ruby
@@ -27,6 +27,8 @@ src_compile() {
}
src_install() {
+ # RUBYOPT=-rauto_gem without rubygems installed will cause ruby to fail, bug #158455
+ unset RUBYOPT
ver=$(${RUBY} -r rbconfig -e 'print Config::CONFIG["MAJOR"] + "." + Config::CONFIG["MINOR"]')
GEM_HOME=${D}/usr/lib/ruby/gems/$ver ruby_src_install
cp "${FILESDIR}/auto_gem.rb" "${D}"/$(${RUBY} -r rbconfig -e 'print Config::CONFIG["sitedir"]')
@@ -46,4 +48,8 @@ pkg_postrm()
# If we potentially downgraded, then getting rid of RUBYOPT from env.d is probably a smart idea.
env-update
source /etc/profile
+ ewarn "You have removed dev-ruby/rubygems. Ruby applications are unlikely"
+ ewarn "to run in current shells because of missing auto_gem."
+ ewarn "Please source /etc/profile in your shells before using ruby"
+ ewarn "or start new shells"
}