summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-10 06:38:42 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-10 06:38:42 +0000
commitb9785235f9a7359c55a0c7da55a6bdf4956ca7c5 (patch)
treed404f0fb24da8301ca40b872d5139cbddeb5e833 /dev-ruby/ruby-prof
parentLink against mathlib for cos(), sin() and more wrt #509928 by Stefan Kalis (diff)
downloadgentoo-2-b9785235f9a7359c55a0c7da55a6bdf4956ca7c5.tar.gz
gentoo-2-b9785235f9a7359c55a0c7da55a6bdf4956ca7c5.tar.bz2
gentoo-2-b9785235f9a7359c55a0c7da55a6bdf4956ca7c5.zip
Version bump. Add ruby20, ruby21.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog7
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index ea73a601655e..ef94ab3eaac9 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.37 2014/05/07 19:09:28 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.38 2014/05/10 06:38:42 graaff Exp $
+
+*ruby-prof-0.15.1 (10 May 2014)
+
+ 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-prof-0.15.1.ebuild:
+ Version bump. Add ruby20, ruby21.
07 May 2014; Manuel Rüger <mrueg@gentoo.org> ruby-prof-0.12.2.ebuild:
Remove ruby18 target.
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild
new file mode 100644
index 000000000000..723e9e1627a1
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.15.1.ebuild,v 1.1 2014/05/10 06:38:42 graaff Exp $
+
+EAPI=5
+
+# jruby → not compatible, since it uses an extension, but there is a bug
+# open for it: https://github.com/rdp/ruby-prof/issues/36
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
+SRC_URI="https://github.com/ruby-prof/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Avoid bundler
+ sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
+
+ sed -i -e '2igem "test-unit"' test/test_helper.rb || die
+
+ # Fix a timing-dependant spec since its thresholds for success are
+ # too tight.
+ sed -i -e '/test_class_methods/,/^ end/ s:^:#:' test/measure_cpu_time_test.rb || die
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb
+
+ # Create directory required for the test suite to pass
+ mkdir tmp || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ruby_prof || die "build failed"
+
+ mkdir lib/ruby_prof || die "unable to create directory for shared object"
+ cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for dir in examples ; do
+ docinto "$dir"
+ dodoc -r "$dir"/*
+ done
+}