summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-08 05:58:38 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-08 05:58:38 +0000
commita0ab7dbf3dd16fb17eccc544be861bc987143cb8 (patch)
tree3041b8c826c296fd356791ece17a8276f2a1d1d5 /dev-ruby/ruby-prof
parentwhitespace (diff)
downloadgentoo-2-a0ab7dbf3dd16fb17eccc544be861bc987143cb8.tar.gz
gentoo-2-a0ab7dbf3dd16fb17eccc544be861bc987143cb8.tar.bz2
gentoo-2-a0ab7dbf3dd16fb17eccc544be861bc987143cb8.zip
Remove old versions.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog6
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.10.2.ebuild76
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.10.6.ebuild74
3 files changed, 5 insertions, 151 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 16e975c8517c..ad9a470f8481 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.32 2011/05/10 06:09:45 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.33 2011/07/08 05:58:38 graaff Exp $
+
+ 08 Jul 2011; Hans de Graaff <graaff@gentoo.org> -ruby-prof-0.10.2.ebuild,
+ -ruby-prof-0.10.6.ebuild:
+ Remove old versions.
*ruby-prof-0.10.7 (10 May 2011)
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.10.2.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.10.2.ebuild
deleted file mode 100644
index b0db3c1a78e7..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.10.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.10.2.ebuild,v 1.1 2011/04/24 08:04:05 graaff Exp $
-
-EAPI=3
-
-# jruby → not compatible, since it uses an extension, but there is a bug
-# open for it: https://github.com/rdp/ruby-prof/issues/36
-# ree18 fails tests, not reported yet.
-
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="https://github.com/rdp/ruby-prof"
-SRC_URI="https://github.com/rdp/${PN}/tarball/${PV} -> ${P}.tgz"
-S="${WORKDIR}/rdp-${PN}-*"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # The thread testing in 0.8.1 and earlier versions is broken, it
- # has to be tested for the next versions, since upstream is
- # looking for a solution. The problem is that it's _very_
- # timing-dependent.
-# rm "${S}"/test/thread_test.rb \
-# || die "unable to remove broken test unit"
-# sed -i -e '/thread_test/d' \
-# test/test_suite.rb || die "unable to remove broken test reference"
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19)
- # On ruby 1.9 this test fails badly, so we disable it
- # until upstream can fix the related bug:
- # http://redmine.ruby-lang.org/issues/show/2012
- sed -i -e '/^ def test_flat_string_with_numbers/,/^ end/ s:^:#:' \
- test/printers_test.rb || die "Unable to disable test_flat_string_with_numbers"
- ;;
- esac
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- # gem ships with prebuild files
- emake -Cext/ruby_prof clean || die "clean failed"
- emake -Cext/ruby_prof || die "build failed"
-
- mkdir lib/ruby_prof || die "unable to create directory for shared object"
- cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples rails rails/example rails/environment; do
- docinto "$dir"
- dodoc "$dir"/* || die "dodoc $dir failed"
- done
-}
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.10.6.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.10.6.ebuild
deleted file mode 100644
index 72b20f18a26f..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.10.6.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.10.6.ebuild,v 1.1 2011/04/30 07:13:45 graaff Exp $
-
-EAPI=4
-
-# jruby → not compatible, since it uses an extension, but there is a bug
-# open for it: https://github.com/rdp/ruby-prof/issues/36
-# ree18 fails tests: https://github.com/rdp/ruby-prof/issues/53.
-
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="https://github.com/rdp/ruby-prof"
-SRC_URI="https://github.com/rdp/${PN}/tarball/${PV} -> ${P}.tgz"
-RUBY_S="rdp-${PN}-*"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # The thread testing in 0.8.1 and earlier versions is broken, it
- # has to be tested for the next versions, since upstream is
- # looking for a solution. The problem is that it's _very_
- # timing-dependent.
-# rm "${S}"/test/thread_test.rb \
-# || die "unable to remove broken test unit"
-# sed -i -e '/thread_test/d' \
-# test/test_suite.rb || die "unable to remove broken test reference"
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19)
- # On ruby 1.9 this test fails badly, so we disable it
- # until upstream can fix the related bug:
- # http://redmine.ruby-lang.org/issues/show/2012
- sed -i -e '/^ def test_flat_string_with_numbers/,/^ end/ s:^:#:' \
- test/printers_test.rb || die "Unable to disable test_flat_string_with_numbers"
- ;;
- esac
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -Cext/ruby_prof || die "build failed"
-
- mkdir lib/ruby_prof || die "unable to create directory for shared object"
- cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples rails rails/example rails/environment; do
- docinto "$dir"
- dodoc -r "$dir"/* || die "dodoc $dir failed"
- done
-}