summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-12 06:03:56 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-12 06:03:56 +0000
commit7bd84cb2caf1df6dab36da89efa691481b767510 (patch)
tree90896fe891315ffd34baeac364a59316a1c5b9df /dev-ruby/ruby-prof
parentAdded patch to fix duplicate filenames in a Makefile - see bug #319443 (diff)
downloadgentoo-2-7bd84cb2caf1df6dab36da89efa691481b767510.tar.gz
gentoo-2-7bd84cb2caf1df6dab36da89efa691481b767510.tar.bz2
gentoo-2-7bd84cb2caf1df6dab36da89efa691481b767510.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog7
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.8.2.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 4559cdab526c..763830ccaa75 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.24 2010/05/22 15:53:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.25 2010/07/12 06:03:56 graaff Exp $
+
+*ruby-prof-0.8.2 (12 Jul 2010)
+
+ 12 Jul 2010; Hans de Graaff <graaff@gentoo.org> +ruby-prof-0.8.2.ebuild:
+ Version bump.
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
ruby-prof-0.7.10.ebuild, ruby-prof-0.8.1.ebuild:
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.8.2.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.8.2.ebuild
new file mode 100644
index 000000000000..1b44a678afe4
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.8.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.8.2.ebuild,v 1.1 2010/07/12 06:03:56 graaff Exp $
+
+EAPI=2
+
+# jruby → not compatible, since it uses an extension
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_EXTRADOC="README CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # The thread testing in 0.8.1 and earlier versions is broken, it
+ # has to be tested for the next versions, since upstream is
+ # looking for a solution. The problem is that it's _very_
+ # timing-dependent.
+ rm "${S}"/test/thread_test.rb \
+ || die "unable to remove broken test unit"
+ sed -i -e '/thread_test/d' \
+ test/test_suite.rb || die "unable to remove broken test reference"
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19)
+ # On ruby 1.9 this test fails badly, so we disable it
+ # until upstream can fix the related bug:
+ # http://redmine.ruby-lang.org/issues/show/2012
+ sed -i -e '/^ def test_flat_string_with_numbers/,/^ end/ s:^:#:' \
+ test/printers_test.rb || die "Unable to disable test_flat_string_with_numbers"
+ ;;
+ esac
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ # gem ships with prebuild files
+ emake -Cext/ruby_prof clean || die "clean failed"
+ emake -Cext/ruby_prof || die "build failed"
+
+ cp ext/ruby_prof/*$(get_modname) lib/ || die "copy of extension failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for dir in examples rails rails/example rails/environment; do
+ docinto "$dir"
+ dodoc "$dir"/* || die "dodoc $dir failed"
+ done
+}