summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerris McCormick <fmccor@gentoo.org>2005-09-21 19:30:23 +0000
committerFerris McCormick <fmccor@gentoo.org>2005-09-21 19:30:23 +0000
commit5dc338088773b4cae28361b5dc2d3dfd80660389 (patch)
tree2a4e1ac2a38416a1613480de53d2dceac4b4060a /dev-ruby/ruby-panel-applet
parentRemove mask of non-existent lighttpd version. (diff)
downloadgentoo-2-5dc338088773b4cae28361b5dc2d3dfd80660389.tar.gz
gentoo-2-5dc338088773b4cae28361b5dc2d3dfd80660389.tar.bz2
gentoo-2-5dc338088773b4cae28361b5dc2d3dfd80660389.zip
Add ~sparc keyword, and in case of sparc, force an explicit dependency on
=gnome-base/gnome-panel-1.4.2-r2. This package will not build on sparc otherwise. I suspect it won't build on anything without such dependency, but I cannot verify, and stable KEYWORDS suggest otherwise. See Bug #55263 for details. (Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-ruby/ruby-panel-applet')
-rw-r--r--dev-ruby/ruby-panel-applet/ChangeLog10
-rw-r--r--dev-ruby/ruby-panel-applet/ruby-panel-applet-0.34.ebuild7
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-ruby/ruby-panel-applet/ChangeLog b/dev-ruby/ruby-panel-applet/ChangeLog
index e65bfb845acf..b076c7f56afb 100644
--- a/dev-ruby/ruby-panel-applet/ChangeLog
+++ b/dev-ruby/ruby-panel-applet/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/ruby-panel-applet
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-panel-applet/ChangeLog,v 1.11 2005/09/02 12:38:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-panel-applet/ChangeLog,v 1.12 2005/09/21 19:30:23 fmccor Exp $
+
+ 21 Sep 2005; Ferris McCormick <fmccor@gentoo.org>
+ ruby-panel-applet-0.34.ebuild:
+ Add ~sparc keyword, and in case of sparc, force an explicit dependency on
+ =gnome-base/gnome-panel-1.4.2-r2. This package will not build on sparc
+ otherwise. I suspect it won't build on anything without such dependency,
+ but I cannot verify, and stable KEYWORDS suggest otherwise. See
+ Bug #55263 for details.
02 Sep 2005; Diego Pettenò <flameeyes@gentoo.org>
ruby-panel-applet-0.30.ebuild, ruby-panel-applet-0.34.ebuild:
diff --git a/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.34.ebuild b/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.34.ebuild
index ed1d0675bd6a..27183059f86a 100644
--- a/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.34.ebuild
+++ b/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.34.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.34.ebuild,v 1.8 2005/09/02 12:38:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.34.ebuild,v 1.9 2005/09/21 19:30:23 fmccor Exp $
inherit ruby
@@ -11,12 +11,13 @@ SRC_URI="mirror://sourceforge/ruby-gnome/ruby-gnome-all-${PV}.tar.gz"
LICENSE="Ruby"
SLOT="0"
-KEYWORDS="x86 alpha"
+KEYWORDS="alpha ~sparc x86"
IUSE=""
USE_RUBY="ruby16 ruby18 ruby19"
DEPEND="virtual/ruby
- >=dev-ruby/ruby-gnome-${PV}"
+ >=dev-ruby/ruby-gnome-${PV}
+ sparc? ( =gnome-base/gnome-panel-1.4.2-r2 )"
src_compile() {
ruby extconf.rb || die "ruby extconf.rb failed"