summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-03-26 20:37:29 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-03-26 20:37:29 +0000
commit714ce1642e574573f0a379eaae7e412d16cbc80c (patch)
tree97cb6de6e7369c50de33a534d597cf2f1a5ed381 /dev-ruby/ruby-opengl
parentVersion bump wrt #482454 by Haydania-Capri DiTori and Bruce Guenter (diff)
downloadgentoo-2-714ce1642e574573f0a379eaae7e412d16cbc80c.tar.gz
gentoo-2-714ce1642e574573f0a379eaae7e412d16cbc80c.tar.bz2
gentoo-2-714ce1642e574573f0a379eaae7e412d16cbc80c.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ruby-opengl')
-rw-r--r--dev-ruby/ruby-opengl/ChangeLog9
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.9.0.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-ruby/ruby-opengl/ChangeLog b/dev-ruby/ruby-opengl/ChangeLog
index 8932e02243ce..f675f742a95e 100644
--- a/dev-ruby/ruby-opengl/ChangeLog
+++ b/dev-ruby/ruby-opengl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-opengl
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ChangeLog,v 1.66 2013/12/29 09:48:57 graaff Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ChangeLog,v 1.67 2014/03/26 20:37:29 mrueg Exp $
+
+*ruby-opengl-0.9.0 (26 Mar 2014)
+
+ 26 Mar 2014; Manuel Rüger <mrueg@gentoo.org> +ruby-opengl-0.9.0.ebuild:
+ Version bump.
29 Dec 2013; Hans de Graaff <graaff@gentoo.org>
-ruby-opengl-0.60.1-r2.ebuild:
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.9.0.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.9.0.ebuild
new file mode 100644
index 000000000000..0a31e69703f7
--- /dev/null
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.9.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ruby-opengl-0.9.0.ebuild,v 1.1 2014/03/26 20:37:29 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# Two tests fails but the README already indicates that this may not
+# work. Additionally these tests require access to video devices such as
+# /dev/nvidiactl.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_NAME="opengl"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="OpenGL / GLUT bindings for ruby"
+HOMEPAGE="http://ruby-opengl.rubyforge.org/ https://github.com/larskanis/opengl"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+DEPEND+=" virtual/opengl
+ media-libs/freeglut"
+RDEPEND+=" virtual/opengl
+ media-libs/freeglut"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/opengl extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/opengl V=1
+
+ cp ext/*/*$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}