summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2013-10-27 18:23:16 +0000
committerAlex Legler <a3li@gentoo.org>2013-10-27 18:23:16 +0000
commit83fe2969961f336abe0e6e140b47f1cf0df3dfb3 (patch)
treec5d62082c0d84a39263feac5de1f678aa09543c4 /dev-ruby/ruby-dict
parentFix bug 488102 - Only call ruby-ng pkg_setup if USE=ruby is set (diff)
downloadgentoo-2-83fe2969961f336abe0e6e140b47f1cf0df3dfb3.tar.gz
gentoo-2-83fe2969961f336abe0e6e140b47f1cf0df3dfb3.tar.bz2
gentoo-2-83fe2969961f336abe0e6e140b47f1cf0df3dfb3.zip
Adding ruby19 support
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 8E740238)
Diffstat (limited to 'dev-ruby/ruby-dict')
-rw-r--r--dev-ruby/ruby-dict/ChangeLog10
-rw-r--r--dev-ruby/ruby-dict/files/ruby-dict-ruby19.patch20
-rw-r--r--dev-ruby/ruby-dict/ruby-dict-0.9.4-r2.ebuild41
3 files changed, 69 insertions, 2 deletions
diff --git a/dev-ruby/ruby-dict/ChangeLog b/dev-ruby/ruby-dict/ChangeLog
index 6440000c9b33..bb83141d2fdc 100644
--- a/dev-ruby/ruby-dict/ChangeLog
+++ b/dev-ruby/ruby-dict/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-dict
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-dict/ChangeLog,v 1.10 2012/05/01 18:24:03 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-dict/ChangeLog,v 1.11 2013/10/27 18:23:15 a3li Exp $
+
+*ruby-dict-0.9.4-r2 (27 Oct 2013)
+
+ 27 Oct 2013; Alex Legler <a3li@gentoo.org> +files/ruby-dict-ruby19.patch,
+ +ruby-dict-0.9.4-r2.ebuild:
+ Adding ruby19 support
01 May 2012; Raúl Porcel <armin76@gentoo.org> ruby-dict-0.9.4-r1.ebuild:
Drop ia64/sparc keywords
diff --git a/dev-ruby/ruby-dict/files/ruby-dict-ruby19.patch b/dev-ruby/ruby-dict/files/ruby-dict-ruby19.patch
new file mode 100644
index 000000000000..5ed897773fac
--- /dev/null
+++ b/dev-ruby/ruby-dict/files/ruby-dict-ruby19.patch
@@ -0,0 +1,20 @@
+--- lib/dict.rb.orig 2013-10-27 19:15:03.957167192 +0100
++++ lib/dict.rb 2013-10-27 19:16:15.191165936 +0100
+@@ -153,7 +153,7 @@
+
+
+ require 'socket'
+-require 'md5'
++require 'digest/md5'
+
+
+ # lines that start with .. need to be reduced to .
+@@ -434,7 +434,7 @@
+ # AUTHorise user
+ #
+ def auth(user, secret)
+- auth = MD5::new(@msgid + secret).hexdigest
++ auth = Digest::MD5.new.hexdigest(@msgid + secret)
+ exec_cmd('AUTH %s %s' % [ user, auth ])
+ end
+
diff --git a/dev-ruby/ruby-dict/ruby-dict-0.9.4-r2.ebuild b/dev-ruby/ruby-dict/ruby-dict-0.9.4-r2.ebuild
new file mode 100644
index 000000000000..463947bf7c58
--- /dev/null
+++ b/dev-ruby/ruby-dict/ruby-dict-0.9.4-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-dict/ruby-dict-0.9.4-r2.ebuild,v 1.1 2013/10/27 18:23:15 a3li Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+inherit ruby-ng
+
+DESCRIPTION="RFC 2229 client in Ruby"
+HOMEPAGE="http://www.caliban.org/ruby/ruby-dict.shtml"
+SRC_URI="http://www.caliban.org/files/ruby/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RUBY_PATCHES=( "${PN}-ruby19.patch" )
+
+each_ruby_test() {
+ ewarn "Tests will use network connection"
+
+ ${RUBY} -Ilib ./rdict test || die
+}
+
+each_ruby_install() {
+ doruby lib/dict.rb || die "doruby failed"
+}
+
+all_ruby_install() {
+ dobin rdict || die "rdict failed"
+
+ dodoc README Changelog TODO doc/rfc2229.txt || die
+ dohtml doc/dict.html doc/rdict.html || die
+
+ # This would probably need a 3rb section..
+ # doman doc/dict.3
+ doman doc/rdict.1 || die "doman failed"
+}