summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-08-16 14:11:12 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-08-16 14:11:12 +0000
commita25b89344dba611b0486bca55333f4dbcdf75337 (patch)
tree60b452dab636981c6313d9989c83ef1040f60397 /dev-ruby/rspec-core
parentCleanup old. (diff)
downloadgentoo-2-a25b89344dba611b0486bca55333f4dbcdf75337.tar.gz
gentoo-2-a25b89344dba611b0486bca55333f4dbcdf75337.tar.bz2
gentoo-2-a25b89344dba611b0486bca55333f4dbcdf75337.zip
Cleanup old.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/rspec-core')
-rw-r--r--dev-ruby/rspec-core/ChangeLog6
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.13.1.ebuild75
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.99.0.ebuild80
3 files changed, 5 insertions, 156 deletions
diff --git a/dev-ruby/rspec-core/ChangeLog b/dev-ruby/rspec-core/ChangeLog
index c048a7c399d6..2b741dbc0c8c 100644
--- a/dev-ruby/rspec-core/ChangeLog
+++ b/dev-ruby/rspec-core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/rspec-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.74 2014/08/13 18:38:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.75 2014/08/16 14:11:12 mrueg Exp $
+
+ 16 Aug 2014; Manuel Rüger <mrueg@gentoo.org> -rspec-core-2.13.1.ebuild,
+ -rspec-core-2.99.0.ebuild:
+ Cleanup old.
13 Aug 2014; Raúl Porcel <armin76@gentoo.org> rspec-core-2.14.8-r1.ebuild,
rspec-core-2.99.0.ebuild, rspec-core-2.99.1.ebuild:
diff --git a/dev-ruby/rspec-core/rspec-core-2.13.1.ebuild b/dev-ruby/rspec-core/rspec-core-2.13.1.ebuild
deleted file mode 100644
index 540e1e195885..000000000000
--- a/dev-ruby/rspec-core/rspec-core-2.13.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.13.1.ebuild,v 1.2 2014/04/05 22:56:33 mrueg Exp $
-
-EAPI=5
-USE_RUBY="ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="none"
-
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-# Also install this custom path since internal paths depend on it.
-RUBY_FAKEGEM_EXTRAINSTALL="exe"
-
-RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="${RDEPEND} !<dev-ruby/rspec-1.3.1-r1"
-
-ruby_add_bdepend "test? (
- >=dev-ruby/nokogiri-1.5.2
- dev-ruby/syntax
- >=dev-ruby/zentest-4.6.2
- dev-ruby/rspec-expectations:2
- >=dev-ruby/rspec-mocks-2.12.0:2
- )"
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Avoid dependency on cucumber since we can't run the features anyway.
- sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
-
- # Also clean the /usr/lib/rubyee path (which is our own invention).
- sed -i -e 's#lib\\d\*\\/ruby\\/#lib\\d*\\/ruby(ee|)\\/#' lib/rspec/core/configuration.rb || die
-
- # Remove jruby-specific comparison documents since for us the normal
- # version passes.
- cp spec/rspec/core/formatters/text_mate_formatted-1.8.7.html spec/rspec/core/formatters/text_mate_formatted-1.8.7-jruby.html|| die
-
- # Duplicate exe also in bin. We can't change it since internal stuff
- # also depends on this and fixing that is going to be fragile. This
- # way we can at least install proper bin scripts.
- cp -R exe bin || die
-
- # Avoid unneeded dependency on git.
- sed -i -e '/git ls-files/ s:^:#:' rspec-core.gemspec || die
-
- # Avoid aruba dependency so that we don't end up in dependency hell.
- sed -i -e '/aruba/ s:^:#:' -e '104,106 s:^:#:' spec/spec_helper.rb || die
- rm spec/command_line/order_spec.rb || die
-}
-
-all_ruby_compile() {
- if use doc ; then
- yardoc || die
- fi
-}
-
-each_ruby_test() {
- PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
-}
diff --git a/dev-ruby/rspec-core/rspec-core-2.99.0.ebuild b/dev-ruby/rspec-core/rspec-core-2.99.0.ebuild
deleted file mode 100644
index ff874da16810..000000000000
--- a/dev-ruby/rspec-core/rspec-core-2.99.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.99.0.ebuild,v 1.3 2014/08/13 18:38:21 armin76 Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="none"
-
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-# Also install this custom path since internal paths depend on it.
-RUBY_FAKEGEM_EXTRAINSTALL="exe"
-
-RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "test? (
- >=dev-ruby/nokogiri-1.5.2
- dev-ruby/syntax
- >=dev-ruby/zentest-4.6.2
- >=dev-ruby/rspec-expectations-2.14.0:2
- >=dev-ruby/rspec-mocks-2.99.0:2
- )"
-
-# Skip yard for ruby20 for now since we don't support ruby20 eselected
-# yet and we can't bootstrap otherwise.
-USE_RUBY=${USE_RUBY/ruby20/} ruby_add_bdepend "doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Avoid dependency on cucumber since we can't run the features anyway.
- sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
-
- # Duplicate exe also in bin. We can't change it since internal stuff
- # also depends on this and fixing that is going to be fragile. This
- # way we can at least install proper bin scripts.
- cp -R exe bin || die
-
- # Avoid unneeded dependency on git.
- sed -i -e '/git ls-files/ s:^:#:' rspec-core.gemspec || die
-
- # Avoid aruba dependency so that we don't end up in dependency hell.
- sed -i -e '/aruba/ s:^:#:' -e '/Aruba/,/}/ s:^:#:' spec/spec_helper.rb || die
- rm spec/command_line/order_spec.rb || die
-}
-
-each_ruby_prepare() {
- sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
-
- case ${RUBY} in
- *jruby)
- # Avoid tests specific to jruby but without jruby 1.6 support.
- sed -e '/JRUBY_VERSION/ s:^:#:' -i spec/rspec/core/filter_manager_spec.rb || die
- ;;
- esac
-}
-
-all_ruby_compile() {
- if use doc ; then
- yardoc || die
- fi
-}
-
-each_ruby_test() {
- PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
-}