summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-19 09:27:40 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-19 09:27:40 +0000
commit0ac2a76bd0c4953b44259a90cb7a5836b0be82dc (patch)
tree97d5bbd9b0c865299a55aa4f380119ffcdc4be6a /dev-ruby/rspec-core
parentVersion bump. (diff)
downloadgentoo-2-0ac2a76bd0c4953b44259a90cb7a5836b0be82dc.tar.gz
gentoo-2-0ac2a76bd0c4953b44259a90cb7a5836b0be82dc.tar.bz2
gentoo-2-0ac2a76bd0c4953b44259a90cb7a5836b0be82dc.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec-core')
-rw-r--r--dev-ruby/rspec-core/ChangeLog7
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.5.1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-ruby/rspec-core/ChangeLog b/dev-ruby/rspec-core/ChangeLog
index f0d6121f49b2..8cb74a46994d 100644
--- a/dev-ruby/rspec-core/ChangeLog
+++ b/dev-ruby/rspec-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec-core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.6 2011/02/02 14:12:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.7 2011/02/19 09:27:40 graaff Exp $
+
+*rspec-core-2.5.1 (19 Feb 2011)
+
+ 19 Feb 2011; Hans de Graaff <graaff@gentoo.org> +rspec-core-2.5.1.ebuild:
+ Version bump.
02 Feb 2011; Diego E. Pettenò <flameeyes@gentoo.org>
rspec-core-2.4.0.ebuild, +files/rspec-core-2.4.0-tests.patch:
diff --git a/dev-ruby/rspec-core/rspec-core-2.5.1.ebuild b/dev-ruby/rspec-core/rspec-core-2.5.1.ebuild
new file mode 100644
index 000000000000..1b0785de204b
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-2.5.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.5.1.ebuild,v 1.1 2011/02/19 09:27:40 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND} !<dev-ruby/rspec-1.3.1-r1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/syntax
+ dev-ruby/rspec-expectations:2
+ dev-ruby/rspec-mocks:2
+ )"
+
+# >=dev-ruby/cucumber-0.5.3
+# >=dev-ruby/autotest-4.2.9
+# dev-ruby/aruba"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # Also clean the /usr/lib/rubyee path (which is our own invention).
+ sed -i -e 's#lib\\d\*\\/ruby\\/#lib\\d*\\/ruby(ee|)\\/#' lib/rspec/core/configuration.rb || die
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ RUBYLIB="${S}/lib" rake rdoc || die "Unable to create documentation."
+ fi
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec || die "Tests failed."
+
+ # There are features but they require aruba which we don't have yet.
+}