summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Kohl <citizen428@gentoo.org>2005-02-03 22:00:12 +0000
committerMichael Kohl <citizen428@gentoo.org>2005-02-03 22:00:12 +0000
commit17c37ff3a8133657f51d9b4c9ca70d76cfe99e6e (patch)
tree6048b37d45d01c90009db5ac3a5f3698e68dd498 /dev-ruby/redcloth/redcloth-3.0.2.ebuild
parentFixed minor issue with the README file's location (diff)
downloadgentoo-2-17c37ff3a8133657f51d9b4c9ca70d76cfe99e6e.tar.gz
gentoo-2-17c37ff3a8133657f51d9b4c9ca70d76cfe99e6e.tar.bz2
gentoo-2-17c37ff3a8133657f51d9b4c9ca70d76cfe99e6e.zip
Version bump.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-ruby/redcloth/redcloth-3.0.2.ebuild')
-rw-r--r--dev-ruby/redcloth/redcloth-3.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/redcloth/redcloth-3.0.2.ebuild b/dev-ruby/redcloth/redcloth-3.0.2.ebuild
new file mode 100644
index 000000000000..cfb4a02979b8
--- /dev/null
+++ b/dev-ruby/redcloth/redcloth-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-3.0.2.ebuild,v 1.1 2005/02/03 22:00:12 citizen428 Exp $
+
+inherit ruby
+
+MY_P="RedCloth-${PV}"
+
+DESCRIPTION="A module for using Textile in Ruby"
+HOMEPAGE="http://www.whytheluckystiff.net/ruby/redcloth/"
+SRC_URI="http://rubyforge.org/frs/download.php/2852/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+USE_RUBY="any"
+DEPEND="virtual/ruby"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ ruby install.rb config --prefix=/usr || die "ruby install.rb config failed"
+ ruby install.rb setup || die "ruby install.rb setup failed"
+}
+
+src_install() {
+ ruby install.rb config --prefix=${D}/usr || die "ruby install.rb config failed"
+ ruby install.rb install || die "ruby install.rb install failed"
+ dodoc doc/CHANGELOG doc/README doc/REFERENCE
+}