summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-05 10:50:36 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-05 10:50:36 +0000
commit1e83b44b5147c556b0d1a8adf1bc45e574b52dfa (patch)
tree985acc7fa41fa2156a92974fe538ae74211ad204 /dev-ruby/rake
parentMasking x11-misc/wmakerconf wrt bug #265465 (diff)
downloadgentoo-2-1e83b44b5147c556b0d1a8adf1bc45e574b52dfa.tar.gz
gentoo-2-1e83b44b5147c556b0d1a8adf1bc45e574b52dfa.tar.bz2
gentoo-2-1e83b44b5147c556b0d1a8adf1bc45e574b52dfa.zip
Revision bump to support stabling jruby.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rake')
-rw-r--r--dev-ruby/rake/ChangeLog10
-rw-r--r--dev-ruby/rake/rake-0.8.7-r4.ebuild6
-rw-r--r--dev-ruby/rake/rake-0.8.7-r5.ebuild49
3 files changed, 61 insertions, 4 deletions
diff --git a/dev-ruby/rake/ChangeLog b/dev-ruby/rake/ChangeLog
index 45a9bad647d9..d0dca84e016a 100644
--- a/dev-ruby/rake/ChangeLog
+++ b/dev-ruby/rake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/rake
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake/ChangeLog,v 1.101 2010/05/22 15:41:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake/ChangeLog,v 1.102 2010/06/05 10:50:36 graaff Exp $
+
+*rake-0.8.7-r5 (05 Jun 2010)
+
+ 05 Jun 2010; Hans de Graaff <graaff@gentoo.org> rake-0.8.7-r4.ebuild,
+ +rake-0.8.7-r5.ebuild:
+ Revision bump so that we can have a stable candidate with jruby support.
+ Keep stable keywords for those arches that do not have jruby keyworded
+ to avoid a pointless stabilization request.
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> -rake-0.8.7.ebuild:
Cleanup old version.
diff --git a/dev-ruby/rake/rake-0.8.7-r4.ebuild b/dev-ruby/rake/rake-0.8.7-r4.ebuild
index ea98bce94d98..de231f4a3eb1 100644
--- a/dev-ruby/rake/rake-0.8.7-r4.ebuild
+++ b/dev-ruby/rake/rake-0.8.7-r4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake/rake-0.8.7-r4.ebuild,v 1.3 2010/05/22 13:33:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake/rake-0.8.7-r4.ebuild,v 1.4 2010/06/05 10:50:36 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 jruby"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST=""
@@ -16,7 +16,7 @@ SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha ~amd64 ~arm hppa ia64 ~ppc ppc64 ~s390 sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="bash-completion doc"
#ruby_add_bdepend test dev-ruby/flexmock
diff --git a/dev-ruby/rake/rake-0.8.7-r5.ebuild b/dev-ruby/rake/rake-0.8.7-r5.ebuild
new file mode 100644
index 000000000000..8e192e7603f5
--- /dev/null
+++ b/dev-ruby/rake/rake-0.8.7-r5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake/rake-0.8.7-r5.ebuild,v 1.1 2010/06/05 10:50:36 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit bash-completion ruby-fakegem
+
+DESCRIPTION="Make-like scripting in Ruby"
+HOMEPAGE="http://rake.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bash-completion doc"
+
+#ruby_add_bdepend test dev-ruby/flexmock
+
+RESTRICT="test"
+
+all_ruby_compile() {
+ if use doc; then
+ ruby -Ilib bin/rake rdoc || die "doc generation failed"
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib bin/rake test || die "tests failed"
+}
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper rake
+
+ if use doc; then
+ pushd html
+ dohtml -r *
+ popd
+ fi
+
+ dodoc CHANGES README TODO || die
+ doman doc/rake.1.gz || die
+
+ dobashcompletion "${FILESDIR}"/rake.bash-completion rake
+}