summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-13 13:15:46 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-13 13:15:46 +0000
commit1ae1776e77e24a5ae9d3e065e540d32d4acc929c (patch)
treeb5c3bcdc6f3fc6eb902d043750ebccd064b25f43 /dev-ruby/rake-compiler
parentBump gitg to 0.2.7 and block 0.2.6 from gnome-3.8 libraries due to a segfault... (diff)
downloadgentoo-2-1ae1776e77e24a5ae9d3e065e540d32d4acc929c.tar.gz
gentoo-2-1ae1776e77e24a5ae9d3e065e540d32d4acc929c.tar.bz2
gentoo-2-1ae1776e77e24a5ae9d3e065e540d32d4acc929c.zip
Version bump.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rake-compiler')
-rw-r--r--dev-ruby/rake-compiler/ChangeLog7
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.8.3.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-ruby/rake-compiler/ChangeLog b/dev-ruby/rake-compiler/ChangeLog
index 8c8687ccc2d2..5f145a356075 100644
--- a/dev-ruby/rake-compiler/ChangeLog
+++ b/dev-ruby/rake-compiler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rake-compiler
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.60 2013/01/15 05:24:38 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.61 2013/04/13 13:15:46 graaff Exp $
+
+*rake-compiler-0.8.3 (13 Apr 2013)
+
+ 13 Apr 2013; Hans de Graaff <graaff@gentoo.org> +rake-compiler-0.8.3.ebuild:
+ Version bump.
15 Jan 2013; Rick Farina <zerochaos@gentoo.org> rake-compiler-0.8.1-r1.ebuild,
rake-compiler-0.8.1.ebuild:
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.8.3.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.8.3.ebuild
new file mode 100644
index 000000000000..6a8e528449c8
--- /dev/null
+++ b/dev-ruby/rake-compiler/rake-compiler-0.8.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.8.3.ebuild,v 1.1 2013/04/13 13:15:46 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
+HOMEPAGE="http://github.com/luislavena/rake-compiler"
+LICENSE="MIT"
+
+SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+RUBY_S="luislavena-${PN}-*"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rake"
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+USE_RUBY=${USE_RUBY/jruby/} ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19|*jruby)
+ # Remove this task so that it won't load on Ruby 1.9 and JRuby
+ # that lack the package_task file. It is, though, needed for the
+ # tests
+ rm tasks/gem.rake || die
+ # Remove specs aimed at a C-compiling ruby implementation.
+ rm spec/lib/rake/extensiontask_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ ruby-ng_rspec
+ ruby-ng_cucumber
+}