summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-08-14 08:05:01 +0000
committerHans de Graaff <graaff@gentoo.org>2010-08-14 08:05:01 +0000
commit502c647edddca79d3bf3b525c1e2284e04146762 (patch)
tree534f5395690e7c6df3d628ccf97df25a6c673d4b /dev-ruby/radiant
parentRevision bump to fix python headers w/ gcc-4.5. Fixes paludis (diff)
downloadgentoo-2-502c647edddca79d3bf3b525c1e2284e04146762.tar.gz
gentoo-2-502c647edddca79d3bf3b525c1e2284e04146762.tar.bz2
gentoo-2-502c647edddca79d3bf3b525c1e2284e04146762.zip
Make sure migration works in the unbundled case, fixes bug 332119.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/radiant')
-rw-r--r--dev-ruby/radiant/ChangeLog8
-rw-r--r--dev-ruby/radiant/files/radiant-0.9.1-unbundled.patch14
-rw-r--r--dev-ruby/radiant/radiant-0.9.1-r3.ebuild50
3 files changed, 71 insertions, 1 deletions
diff --git a/dev-ruby/radiant/ChangeLog b/dev-ruby/radiant/ChangeLog
index da44aea1b0ea..98357be3fc2e 100644
--- a/dev-ruby/radiant/ChangeLog
+++ b/dev-ruby/radiant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/radiant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/radiant/ChangeLog,v 1.20 2010/08/13 06:31:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/radiant/ChangeLog,v 1.21 2010/08/14 08:05:01 graaff Exp $
+
+*radiant-0.9.1-r3 (14 Aug 2010)
+
+ 14 Aug 2010; Hans de Graaff <graaff@gentoo.org> +radiant-0.9.1-r3.ebuild,
+ files/radiant-0.9.1-unbundled.patch:
+ Make sure migration works in the unbundled case, fixes bug 332119.
13 Aug 2010; Hans de Graaff <graaff@gentoo.org> -radiant-0.8.1.ebuild,
-radiant-0.8.2.ebuild, -radiant-0.9.1.ebuild:
diff --git a/dev-ruby/radiant/files/radiant-0.9.1-unbundled.patch b/dev-ruby/radiant/files/radiant-0.9.1-unbundled.patch
index 9d9053097426..c72c642767b3 100644
--- a/dev-ruby/radiant/files/radiant-0.9.1-unbundled.patch
+++ b/dev-ruby/radiant/files/radiant-0.9.1-unbundled.patch
@@ -18,3 +18,17 @@
require 'rails_generator/scripts/generate'
class Rails::Generator::Base
+--- lib/tasks/database.rake.~1~ 2010-08-14 09:59:40.322355364 +0200
++++ lib/tasks/database.rake 2010-08-14 10:01:28.405760795 +0200
+@@ -28,4 +28,9 @@
+ :database_template => ENV['DATABASE_TEMPLATE']
+ )
+ end
+-end
+\ No newline at end of file
++
++ desc "Migrate schema to latest version"
++ task :migrate do
++ ActiveRecord::Migrator.migrate("#{RADIANT_ROOT}/db/migrate/")
++ end
++end
diff --git a/dev-ruby/radiant/radiant-0.9.1-r3.ebuild b/dev-ruby/radiant/radiant-0.9.1-r3.ebuild
new file mode 100644
index 000000000000..6da2f456730c
--- /dev/null
+++ b/dev-ruby/radiant/radiant-0.9.1-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/radiant/radiant-0.9.1-r3.ebuild,v 1.1 2010/08/14 08:05:01 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="spec cucumber"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG CONTRIBUTORS README"
+
+# All these files are needed because the generator expect to install them.
+RUBY_FAKEGEM_EXTRAINSTALL="CHANGELOG CONTRIBUTORS INSTALL LICENSE README Rakefile app config db log public script vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A no-fluff, open source content management system"
+HOMEPAGE="http://radiantcms.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Testing depends on a working database and a bundled version of Rails 2.3.8
+# Needs more work later.
+RESTRICT="test"
+
+#ruby_add_bdepend "test? ( dev-db/sqlite3-ruby dev-ruby/rspec dev-util/cucumber )"
+
+ruby_add_rdepend ">=dev-ruby/redcloth-4.0.0
+ >=dev-ruby/rack-1.1.0
+ =dev-ruby/rails-2.3*
+ >=dev-ruby/highline-1.5.1
+ >=dev-ruby/radius-0.5.1
+ =dev-ruby/will_paginate-2.3*"
+
+# Remove code from vendor that we support as an external dependency.
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${P}-unbundled.patch"
+
+ rm -rf vendor/{highline,radius,rails,redcloth} || die "Unable to remove vendored code."
+}
+
+each_ruby_test() {
+ cp config/database.sqlite.yml config/database.yml || die "Unable to provide database.yml for testing."
+ ${RUBY} -S rake db:migrate
+ each_fakegem_test
+ rm config/database.yml || die "Unable to remove testing database.yml."
+}