summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-01 09:23:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-01 09:23:10 +0000
commitb40e8c8ddd0cf24ded2b1ea1664c86edc78dc7dc (patch)
treeebe153979cba105c68664e7c7159a0a688c8f52c /dev-ruby/prawn-layout
parentVersion bump. (diff)
downloadgentoo-2-b40e8c8ddd0cf24ded2b1ea1664c86edc78dc7dc.tar.gz
gentoo-2-b40e8c8ddd0cf24ded2b1ea1664c86edc78dc7dc.tar.bz2
gentoo-2-b40e8c8ddd0cf24ded2b1ea1664c86edc78dc7dc.zip
Version bump.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/prawn-layout')
-rw-r--r--dev-ruby/prawn-layout/ChangeLog8
-rw-r--r--dev-ruby/prawn-layout/prawn-layout-0.7.2.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/prawn-layout/ChangeLog b/dev-ruby/prawn-layout/ChangeLog
index 8c64d44bb95c..73ff16a38d90 100644
--- a/dev-ruby/prawn-layout/ChangeLog
+++ b/dev-ruby/prawn-layout/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/prawn-layout
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-layout/ChangeLog,v 1.3 2010/01/28 19:15:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-layout/ChangeLog,v 1.4 2010/02/01 09:23:09 flameeyes Exp $
+
+*prawn-layout-0.7.2 (01 Feb 2010)
+
+ 01 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +prawn-layout-0.7.2.ebuild:
+ Version bump.
28 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
prawn-layout-0.7.1.ebuild:
diff --git a/dev-ruby/prawn-layout/prawn-layout-0.7.2.ebuild b/dev-ruby/prawn-layout/prawn-layout-0.7.2.ebuild
new file mode 100644
index 000000000000..6ed81d4ecebc
--- /dev/null
+++ b/dev-ruby/prawn-layout/prawn-layout-0.7.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-layout/prawn-layout-0.7.2.ebuild,v 1.1 2010/02/01 09:23:10 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="An extension to Prawn offering table support, grid layouts and other things"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+ruby_add_bdepend test "dev-ruby/test-spec dev-ruby/mocha"
+
+ruby_add_rdepend "=dev-ruby/prawn-core-$(get_version_component_range 1-2)*"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}