summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-03-04 07:48:49 +0000
committerHans de Graaff <graaff@gentoo.org>2010-03-04 07:48:49 +0000
commita051a75a62d7cad796ea1ea3bfef3e43dad1456a (patch)
tree604c4998646a5370d8bc18163eaa78628485c2ef /dev-ruby/polyglot
parentVersion bump (diff)
downloadgentoo-2-a051a75a62d7cad796ea1ea3bfef3e43dad1456a.tar.gz
gentoo-2-a051a75a62d7cad796ea1ea3bfef3e43dad1456a.tar.bz2
gentoo-2-a051a75a62d7cad796ea1ea3bfef3e43dad1456a.zip
Version bump.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/polyglot')
-rw-r--r--dev-ruby/polyglot/ChangeLog7
-rw-r--r--dev-ruby/polyglot/polyglot-0.3.0.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/polyglot/ChangeLog b/dev-ruby/polyglot/ChangeLog
index bfeaf4ad6e55..be74167dfcea 100644
--- a/dev-ruby/polyglot/ChangeLog
+++ b/dev-ruby/polyglot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/polyglot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/ChangeLog,v 1.10 2010/02/13 19:36:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/ChangeLog,v 1.11 2010/03/04 07:48:49 graaff Exp $
+
+*polyglot-0.3.0 (04 Mar 2010)
+
+ 04 Mar 2010; Hans de Graaff <graaff@gentoo.org> +polyglot-0.3.0.ebuild:
+ Version bump.
13 Feb 2010; Raúl Porcel <armin76@gentoo.org> polyglot-0.2.9.ebuild,
polyglot-0.2.9-r1.ebuild:
diff --git a/dev-ruby/polyglot/polyglot-0.3.0.ebuild b/dev-ruby/polyglot/polyglot-0.3.0.ebuild
new file mode 100644
index 000000000000..bfdf04fcee68
--- /dev/null
+++ b/dev-ruby/polyglot/polyglot-0.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/polyglot-0.3.0.ebuild,v 1.1 2010/03/04 07:48:49 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Polyglot provides support for fully-custom DSLs."
+HOMEPAGE="http://polyglot.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend test virtual/ruby-test-unit
+
+each_ruby_test() {
+ ${RUBY} test/test_polyglot.rb || die "tests failed"
+}