summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-11 13:35:17 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-11 13:35:17 +0000
commitaedff42ed0fe87e19c945ad73d59a8335ba9aeb9 (patch)
tree63d12e58f5c1115bdf8b8f276e59abeec86d70d3 /dev-ruby/pg
parentAdd ruby20 target. Cleanup old. (diff)
downloadgentoo-2-aedff42ed0fe87e19c945ad73d59a8335ba9aeb9.tar.gz
gentoo-2-aedff42ed0fe87e19c945ad73d59a8335ba9aeb9.tar.bz2
gentoo-2-aedff42ed0fe87e19c945ad73d59a8335ba9aeb9.zip
Add ruby20 target. Cleanup old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/ChangeLog8
-rw-r--r--dev-ruby/pg/pg-0.17.0-r1.ebuild (renamed from dev-ruby/pg/pg-0.16.0.ebuild)4
-rw-r--r--dev-ruby/pg/pg-0.17.0.ebuild66
3 files changed, 9 insertions, 69 deletions
diff --git a/dev-ruby/pg/ChangeLog b/dev-ruby/pg/ChangeLog
index 5ce0ff9c4562..b6b3534f844b 100644
--- a/dev-ruby/pg/ChangeLog
+++ b/dev-ruby/pg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/pg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.65 2013/09/23 07:02:05 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.66 2013/11/11 13:35:17 mrueg Exp $
+
+*pg-0.17.0-r1 (11 Nov 2013)
+
+ 11 Nov 2013; Manuel Rüger <mrueg@gentoo.org> +pg-0.17.0-r1.ebuild,
+ -pg-0.16.0.ebuild, -pg-0.17.0.ebuild:
+ Add ruby20 target. Cleanup old.
*pg-0.17.0 (23 Sep 2013)
diff --git a/dev-ruby/pg/pg-0.16.0.ebuild b/dev-ruby/pg/pg-0.17.0-r1.ebuild
index 2c9c1d7dabd5..1afa6ef3f017 100644
--- a/dev-ruby/pg/pg-0.16.0.ebuild
+++ b/dev-ruby/pg/pg-0.17.0-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.16.0.ebuild,v 1.1 2013/08/22 08:38:20 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.17.0-r1.ebuild,v 1.1 2013/11/11 13:35:17 mrueg Exp $
EAPI=5
-USE_RUBY="ruby18 ruby19"
+USE_RUBY="ruby18 ruby19 ruby20"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
diff --git a/dev-ruby/pg/pg-0.17.0.ebuild b/dev-ruby/pg/pg-0.17.0.ebuild
deleted file mode 100644
index 51d755dd339d..000000000000
--- a/dev-ruby/pg/pg-0.17.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.17.0.ebuild,v 1.1 2013/09/23 07:02:05 mrueg Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_TASK_DOC="redocs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors.rdoc README.rdoc History.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
-HOMEPAGE="http://bitbucket.org/ged/ruby-pg/"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="${RDEPEND}
- dev-db/postgresql-base"
-DEPEND="${DEPEND}
- dev-db/postgresql-base
- test? ( dev-db/postgresql-server )"
-
-ruby_add_bdepend "
- doc? (
- dev-ruby/hoe
- || ( >=dev-ruby/yard-0.6.1 dev-ruby/rdoc ) )"
-
-all_ruby_prepare() {
- # hack the Rakefile to make it sure that it doesn't load
- # rake-compiler (so that we don't have to depend on it and it
- # actually works when building with USE=doc).
- sed -i \
- -e '/Rakefile.cross/s:^:#:' \
- -e '/ExtensionTask/,/^end$/ s:^:#:' \
- Rakefile || die
-
- sed -i -e '18i require "socket"' spec/pg/connection_spec.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- cp ext/*$(get_libname) lib || die
-}
-
-each_ruby_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- # Make the rspec call explicit, this way we don't have to depend
- # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
- # the whole extension from scratch.
- ruby-ng_rspec
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}