summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-16 07:27:18 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-16 07:27:18 +0000
commit2c62eb9476185f59ebb4b68d439adb2b7cb84817 (patch)
treee9773a25a7ac7b38dcfc3c61c75f12da980186b3 /dev-ruby/nokogiri
parentVersion bump. (diff)
downloadgentoo-2-2c62eb9476185f59ebb4b68d439adb2b7cb84817.tar.gz
gentoo-2-2c62eb9476185f59ebb4b68d439adb2b7cb84817.tar.bz2
gentoo-2-2c62eb9476185f59ebb4b68d439adb2b7cb84817.zip
Remove old versions.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/nokogiri')
-rw-r--r--dev-ruby/nokogiri/ChangeLog6
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.4.1-r1.ebuild43
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.4.3.1-r1.ebuild75
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.4.3.1.ebuild75
4 files changed, 5 insertions, 194 deletions
diff --git a/dev-ruby/nokogiri/ChangeLog b/dev-ruby/nokogiri/ChangeLog
index a83f06756f73..a4a615240b86 100644
--- a/dev-ruby/nokogiri/ChangeLog
+++ b/dev-ruby/nokogiri/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/nokogiri
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.48 2011/02/02 13:34:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.49 2011/02/16 07:27:18 graaff Exp $
+
+ 16 Feb 2011; Hans de Graaff <graaff@gentoo.org> -nokogiri-1.4.1-r1.ebuild,
+ -nokogiri-1.4.3.1.ebuild, -nokogiri-1.4.3.1-r1.ebuild:
+ Remove old versions.
02 Feb 2011; Diego E. Pettenò <flameeyes@gentoo.org> nokogiri-1.4.4.ebuild:
Add missing racc dependency; skip tests for JRuby since they require
diff --git a/dev-ruby/nokogiri/nokogiri-1.4.1-r1.ebuild b/dev-ruby/nokogiri/nokogiri-1.4.1-r1.ebuild
deleted file mode 100644
index d409909ff795..000000000000
--- a/dev-ruby/nokogiri/nokogiri-1.4.1-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.4.1-r1.ebuild,v 1.11 2010/11/29 08:12:16 graaff Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
-HOMEPAGE="http://nokogiri.rubyforge.org/"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-SLOT="0"
-IUSE=""
-
-RDEPEND="dev-libs/libxml2
- dev-libs/libxslt"
-DEPEND="${RDEPEND}"
-
-ruby_add_bdepend "dev-ruby/rake-compiler dev-ruby/rexical dev-ruby/hoe"
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${P}-ruby19.patch
-}
-
-each_ruby_compile() {
- case ${RUBY} in
- *jruby)
- einfo "NokoGiri does not build a native extension for JRury."
- einfo "Instead, the FFI library will be used."
- ;;
- *)
- ${RUBY} -S rake compile || die "extension build failed"
- ;;
- esac
-}
diff --git a/dev-ruby/nokogiri/nokogiri-1.4.3.1-r1.ebuild b/dev-ruby/nokogiri/nokogiri-1.4.3.1-r1.ebuild
deleted file mode 100644
index ebf499e21435..000000000000
--- a/dev-ruby/nokogiri/nokogiri-1.4.3.1-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.4.3.1-r1.ebuild,v 1.5 2010/12/18 08:44:52 graaff Exp $
-
-EAPI=2
-
-# jruby → needs weakling for testing , will add back in a bit
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
-HOMEPAGE="http://nokogiri.rubyforge.org/"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-SLOT="0"
-IUSE="ffi"
-
-RDEPEND="${RDEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-DEPEND="${DEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-
-# The tests require _minitest_, not the virtual; what is shipped with
-# Ruby 1.9 is *not* enough, unfortunately
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- dev-ruby/rexical
- dev-ruby/hoe
- test? ( dev-ruby/minitest )"
-
-ruby_add_rdepend "ffi? ( virtual/ruby-ffi )"
-
-# USE_RUBY=jruby \
-# ruby_add_bdepend "test? ( dev-ruby/weakling )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/tasks\/cross_compile/s:^:#:' \
- -e '/:test.*prerequisites/s:^:#:' \
- Rakefile || die
-}
-
-nokogiri_ffi() {
- [[ $(basename ${RUBY}) == "jruby" ]] || use ffi
-}
-
-each_ruby_configure() {
- nokogiri_ffi && return
- ${RUBY} -Cext/${PN} extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- if ! [[ -f lib/nokogiri/css/generated_tokenizer.rb ]]; then
- ${RUBY} -S rake lib/nokogiri/css/generated_tokenizer.rb || die "rexical failed"
- fi
-
- nokogiri_ffi && return
- emake -Cext/${PN} \
- CFLAGS="${CFLAGS} -fPIC" \
- archflag="${LDFLAGS}" || die "make extension failed"
- cp -l ext/${PN}/${PN}.so lib/${PN}/ || die
-}
-
-each_ruby_test() {
- nokogiri_ffi && export NOKOGIRI_FFI=yes
- each_fakegem_test
-}
diff --git a/dev-ruby/nokogiri/nokogiri-1.4.3.1.ebuild b/dev-ruby/nokogiri/nokogiri-1.4.3.1.ebuild
deleted file mode 100644
index 19e07f0d4200..000000000000
--- a/dev-ruby/nokogiri/nokogiri-1.4.3.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.4.3.1.ebuild,v 1.6 2010/10/25 01:51:23 jer Exp $
-
-EAPI=2
-
-# jruby → needs weakling for testing , will add back in a bit
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
-HOMEPAGE="http://nokogiri.rubyforge.org/"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-SLOT="0"
-IUSE="ffi"
-
-RDEPEND="${RDEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-DEPEND="${DEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-
-# The tests require _minitest_, not the virtual; what is shipped with
-# Ruby 1.9 is *not* enough, unfortunately
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- dev-ruby/rexical
- dev-ruby/hoe
- test? ( dev-ruby/minitest )"
-
-ruby_add_rdepend "ffi? ( virtual/ruby-ffi )"
-
-# USE_RUBY=jruby \
-# ruby_add_bdepend "test? ( dev-ruby/weakling )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/tasks\/cross_compile/s:^:#:' \
- -e '/:test.*prerequisites/s:^:#:' \
- Rakefile || die
-}
-
-nokogiri_ffi() {
- [[ $(basename ${RUBY}) == "jruby" ]] || use ffi
-}
-
-each_ruby_configure() {
- nokogiri_ffi && return
- ${RUBY} -Cext/${PN} extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- if ! [[ -f lib/nokogiri/css/generated_tokenizer.rb ]]; then
- ${RUBY} -S rake lib/nokogiri/css/generated_tokenizer.rb || die "rexical failed"
- fi
-
- nokogiri_ffi && return
- emake -Cext/${PN} \
- CFLAGS="${CFLAGS} -fPIC" \
- archflag="${LDFLAGS}" || die "make extension failed"
- cp -l ext/${PN}/${PN}.so lib/${PN}/ || die
-}
-
-each_ruby_test() {
- nokogiri_ffi && export NOKOGIRI_FFI=yes
- each_fakegem_test
-}