summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-07-07 21:56:25 +0000
committerTom William Payne <twp@gentoo.org>2003-07-07 21:56:25 +0000
commitd0830e7982e865f472879a11f86dc7ec08068998 (patch)
treefbd304240fc666ddd1acbcbd89144d4fcb936a74 /dev-ruby/ncurses-ruby/ncurses-ruby-0.7.1.ebuild
parentInitial commit (diff)
downloadgentoo-2-d0830e7982e865f472879a11f86dc7ec08068998.tar.gz
gentoo-2-d0830e7982e865f472879a11f86dc7ec08068998.tar.bz2
gentoo-2-d0830e7982e865f472879a11f86dc7ec08068998.zip
Initial commit
Diffstat (limited to 'dev-ruby/ncurses-ruby/ncurses-ruby-0.7.1.ebuild')
-rw-r--r--dev-ruby/ncurses-ruby/ncurses-ruby-0.7.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/ncurses-ruby/ncurses-ruby-0.7.1.ebuild b/dev-ruby/ncurses-ruby/ncurses-ruby-0.7.1.ebuild
new file mode 100644
index 000000000000..4a87f1cfb2f3
--- /dev/null
+++ b/dev-ruby/ncurses-ruby/ncurses-ruby-0.7.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ncurses-ruby/ncurses-ruby-0.7.1.ebuild,v 1.1 2003/07/07 21:56:06 twp Exp $
+
+DESCRIPTION="Ruby wrappers of ncurses and PDCurses libs"
+HOMEPAGE="http://ncurses-ruby.berlios.de/"
+SRC_URI="http://download.berlios.de/ncurses-ruby/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~sparc ~x86"
+IUSE=""
+DEPEND=">=dev-lang/ruby-1.6
+ >=sys-libs/ncurses-5.3"
+
+src_compile() {
+ ruby extconf.rb || die
+ emake || die
+}
+
+src_install() {
+ einstall
+}