summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-04 17:49:47 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-04 17:49:47 +0000
commit78776c11a98a107ccc8bd71498e3ae5ccf0174db (patch)
tree7fc0f10e6ca73b0868f7325459959bc100a40b01 /dev-ruby/narray
parentAdd ruby20 target. Cleanup old. (diff)
downloadgentoo-2-78776c11a98a107ccc8bd71498e3ae5ccf0174db.tar.gz
gentoo-2-78776c11a98a107ccc8bd71498e3ae5ccf0174db.tar.bz2
gentoo-2-78776c11a98a107ccc8bd71498e3ae5ccf0174db.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/narray')
-rw-r--r--dev-ruby/narray/ChangeLog7
-rw-r--r--dev-ruby/narray/narray-0.6.0.8-r1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/narray/ChangeLog b/dev-ruby/narray/ChangeLog
index 5608dce1e0c4..f5099942b9ff 100644
--- a/dev-ruby/narray/ChangeLog
+++ b/dev-ruby/narray/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/narray
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.59 2013/08/11 07:41:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.60 2013/10/04 17:49:47 mrueg Exp $
+
+*narray-0.6.0.8-r1 (04 Oct 2013)
+
+ 04 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +narray-0.6.0.8-r1.ebuild:
+ Add ruby20 target.
11 Aug 2013; Hans de Graaff <graaff@gentoo.org> -narray-0.6.0.1.ebuild:
Cleanup.
diff --git a/dev-ruby/narray/narray-0.6.0.8-r1.ebuild b/dev-ruby/narray/narray-0.6.0.8-r1.ebuild
new file mode 100644
index 000000000000..e2f90633cf7a
--- /dev/null
+++ b/dev-ruby/narray/narray-0.6.0.8-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.6.0.8-r1.ebuild,v 1.1 2013/10/04 17:49:47 mrueg Exp $
+
+EAPI=5
+
+# jruby → native extension
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.en README.ja SPEC.en SPEC.ja"
+
+RUBY_FAKEGEM_VERSION="${PV/_p/.}"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="https://github.com/masa16/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+RUBY_PATCHES=( "${FILESDIR}"/${P}-fix-tests.patch )
+
+all_ruby_prepare() {
+ # the tests aren't really written to be a testsuite, so the
+ # failure cases will literally fail; ignore all of those ad
+ # instead expect that the rest won't fail.
+ sed -i -e '/[fF]ollowing will fail/,$ s:^:#:' \
+ -e '/next will fail/,$ s:^:#:' \
+ test/*.rb || die "sed failed"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp -l ${PN}$(get_modname) ${PN}.h ${PN}_config.h lib/ || die "copy of ${PN}$(get_modname) failed"
+}
+
+each_ruby_test() {
+ for unit in test/*; do
+ # Skip over the FFTW test because it needs a package we don't
+ # have in tree.
+ [[ ${unit} == test/testfftw.rb ]] && continue
+
+ ${RUBY} -Ilib ${unit} || die "test ${unit} failed"
+ done
+}