summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 04:32:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 04:32:48 +0000
commita01512c02ed49013a9c9bb5826ad1ea923db1f4c (patch)
tree8b9e13b4112800a5cd00ecba2359e1bc8ea384eb /dev-ruby/multi_xml
parentRenamed 'gnome' USE flag to 'gtk', since non-gnome users probably want it too... (diff)
downloadgentoo-2-a01512c02ed49013a9c9bb5826ad1ea923db1f4c.tar.gz
gentoo-2-a01512c02ed49013a9c9bb5826ad1ea923db1f4c.tar.bz2
gentoo-2-a01512c02ed49013a9c9bb5826ad1ea923db1f4c.zip
Port to rspec helper for testing.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/multi_xml')
-rw-r--r--dev-ruby/multi_xml/ChangeLog6
-rw-r--r--dev-ruby/multi_xml/multi_xml-0.5.1.ebuild15
2 files changed, 10 insertions, 11 deletions
diff --git a/dev-ruby/multi_xml/ChangeLog b/dev-ruby/multi_xml/ChangeLog
index 357b24800788..1ddc3a37af1c 100644
--- a/dev-ruby/multi_xml/ChangeLog
+++ b/dev-ruby/multi_xml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/multi_xml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_xml/ChangeLog,v 1.9 2012/05/17 15:37:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_xml/ChangeLog,v 1.10 2012/08/14 04:32:48 flameeyes Exp $
+
+ 14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> multi_xml-0.5.1.ebuild:
+ Port to rspec helper for testing.
*multi_xml-0.5.1 (17 May 2012)
@@ -43,4 +46,3 @@
20 Jul 2011; Hans de Graaff <graaff@gentoo.org> +multi_xml-0.2.2.ebuild,
+metadata.xml:
Initial import. New dependency of dev-ruby/twitter.
-
diff --git a/dev-ruby/multi_xml/multi_xml-0.5.1.ebuild b/dev-ruby/multi_xml/multi_xml-0.5.1.ebuild
index ba40d839c833..1bac8935576d 100644
--- a/dev-ruby/multi_xml/multi_xml-0.5.1.ebuild
+++ b/dev-ruby/multi_xml/multi_xml-0.5.1.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_xml/multi_xml-0.5.1.ebuild,v 1.1 2012/05/17 15:37:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_xml/multi_xml-0.5.1.ebuild,v 1.2 2012/08/14 04:32:48 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ree18 ruby19 jruby"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_TASK_DOC="doc:yard"
+
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_TASK_TEST="spec"
-
inherit ruby-fakegem
DESCRIPTION="A generic swappable back-end for XML parsing"
@@ -23,15 +23,12 @@ SLOT="0"
IUSE=""
ruby_add_bdepend "doc? ( dev-ruby/yard )"
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5:2 )"
all_ruby_prepare() {
- rm Gemfile || die
-
- # Remove possible incompatible rspec options.
- rm .rspec || die
+ # Remove possible incompatible rspec options and bundler.
+ rm Gemfile .rspec || die
}
each_ruby_test() {
- CI=true ${RUBY} -S rspec spec || die
+ CI=true each_fakegem_test
}