summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-30 11:52:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-30 11:52:40 +0000
commit5ca6a9bf6394a057d5e980da0a73384d8b87c096 (patch)
treeb50ac0193400836c8092edb5092ab059e33167b9 /dev-ruby/libxml
parentBump for mono-2 (diff)
downloadgentoo-2-5ca6a9bf6394a057d5e980da0a73384d8b87c096.tar.gz
gentoo-2-5ca6a9bf6394a057d5e980da0a73384d8b87c096.tar.bz2
gentoo-2-5ca6a9bf6394a057d5e980da0a73384d8b87c096.zip
Version bump; use the tarball rather than the gem so that the tests run during src_test. Fix license, it's actually as-is rather than BSD.
(Portage version: 2.2_rc16/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'dev-ruby/libxml')
-rw-r--r--dev-ruby/libxml/ChangeLog9
-rw-r--r--dev-ruby/libxml/libxml-0.9.5.ebuild51
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index bb3508db3701..b3a40e46dd34 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.18 2008/10/13 15:21:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.19 2008/11/30 11:52:40 flameeyes Exp $
+
+*libxml-0.9.5 (30 Nov 2008)
+
+ 30 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libxml-0.9.5.ebuild:
+ Version bump; use the tarball rather than the gem so that the tests run
+ during src_test. Fix license, it's actually as-is rather than BSD.
*libxml-0.8.3 (13 Oct 2008)
diff --git a/dev-ruby/libxml/libxml-0.9.5.ebuild b/dev-ruby/libxml/libxml-0.9.5.ebuild
new file mode 100644
index 000000000000..bb661f575028
--- /dev/null
+++ b/dev-ruby/libxml/libxml-0.9.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-0.9.5.ebuild,v 1.1 2008/11/30 11:52:40 flameeyes Exp $
+
+inherit ruby
+
+MY_P=${PN}-ruby-${PV}
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+SRC_URI="mirror://rubyforge/${PN}/${MY_P}.tgz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="" # doc
+
+RDEPEND=">=dev-libs/libxml2-2.6.6"
+DEPEND="${RDEPEND}
+ dev-ruby/rake"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ rake extensions || die "rake extensions failed"
+
+ # Does not work on 0.9.5
+ #if use doc; then
+ # rake rdoc || die "rake rdoc failed"
+ #fi
+}
+
+src_test() {
+ rake test || die "rake test failed"
+}
+
+src_install() {
+ cd "${S}"/lib
+ doruby -r * || die "doruby failed"
+
+ cd "${S}"/ext/libxml
+ ruby_einstall || die "ruby_einstall failed"
+
+ cd "${S}"
+
+ dodoc README CHANGES || die "dodoc failed"
+
+ #if use doc; then
+ # dohtml -r doc/* || die "dohtml failed"
+ #fi
+}