summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-04 03:57:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-04 03:57:38 +0000
commitaaf9a02df68111eac28bbbb3f782becb39aa6870 (patch)
treeff18f851b53f567a3e8af4cbd309e366f4a155ee /dev-ruby/jruby-openssl
parentAdd support for JRuby (although it has a possibly cyclic dependency over jrub... (diff)
downloadgentoo-2-aaf9a02df68111eac28bbbb3f782becb39aa6870.tar.gz
gentoo-2-aaf9a02df68111eac28bbbb3f782becb39aa6870.tar.bz2
gentoo-2-aaf9a02df68111eac28bbbb3f782becb39aa6870.zip
Bump jruby-openssl to fakegem, and drop older version that polluted Ruby 1.8 space.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/jruby-openssl')
-rw-r--r--dev-ruby/jruby-openssl/ChangeLog10
-rw-r--r--dev-ruby/jruby-openssl/jruby-openssl-0.2.3.ebuild17
-rw-r--r--dev-ruby/jruby-openssl/jruby-openssl-0.6-r1.ebuild30
-rw-r--r--dev-ruby/jruby-openssl/jruby-openssl-0.6.ebuild17
4 files changed, 39 insertions, 35 deletions
diff --git a/dev-ruby/jruby-openssl/ChangeLog b/dev-ruby/jruby-openssl/ChangeLog
index d4adc3346c21..7bb95abef424 100644
--- a/dev-ruby/jruby-openssl/ChangeLog
+++ b/dev-ruby/jruby-openssl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/jruby-openssl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jruby-openssl/ChangeLog,v 1.3 2010/01/01 03:41:21 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jruby-openssl/ChangeLog,v 1.4 2010/01/04 03:57:38 flameeyes Exp $
+
+*jruby-openssl-0.6-r1 (04 Jan 2010)
+
+ 04 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -jruby-openssl-0.2.3.ebuild, -jruby-openssl-0.6.ebuild,
+ +jruby-openssl-0.6-r1.ebuild:
+ Bump jruby-openssl to fakegem, and drop older version that polluted Ruby
+ 1.8 space.
*jruby-openssl-0.6 (01 Jan 2010)
diff --git a/dev-ruby/jruby-openssl/jruby-openssl-0.2.3.ebuild b/dev-ruby/jruby-openssl/jruby-openssl-0.2.3.ebuild
deleted file mode 100644
index 552b980cc883..000000000000
--- a/dev-ruby/jruby-openssl/jruby-openssl-0.2.3.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jruby-openssl/jruby-openssl-0.2.3.ebuild,v 1.2 2009/10/25 21:48:16 volkmar Exp $
-
-inherit ruby gems
-
-USE_RUBY="ruby18"
-DESCRIPTION="A Ruby SSL library that works with JRuby"
-HOMEPAGE="http://rubyforge.org/projects/jruby-extras"
-SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="dev-java/jruby"
diff --git a/dev-ruby/jruby-openssl/jruby-openssl-0.6-r1.ebuild b/dev-ruby/jruby-openssl/jruby-openssl-0.6-r1.ebuild
new file mode 100644
index 000000000000..f68d8b99dd8f
--- /dev/null
+++ b/dev-ruby/jruby-openssl/jruby-openssl-0.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jruby-openssl/jruby-openssl-0.6-r1.ebuild,v 1.1 2010/01/04 03:57:38 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY=jruby
+
+RUBY_FAKEGEM_TASK_DOC="redocs"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+# Seems like the PKCS7 support requires the BouncyCastle JARs that are
+# shipped but somewhat fails; unfortunately, this package does not
+# provide the source files, so we cannot really rebuild this.
+RESTRICT=test
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby SSL library that works with JRuby"
+HOMEPAGE="http://rubyforge.org/projects/jruby-extras"
+
+LICENSE="MIT || ( CPL-1.0 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend doc dev-ruby/hoe
+#ruby_add_bdepend test dev-ruby/hoe
diff --git a/dev-ruby/jruby-openssl/jruby-openssl-0.6.ebuild b/dev-ruby/jruby-openssl/jruby-openssl-0.6.ebuild
deleted file mode 100644
index 4597a1b0836c..000000000000
--- a/dev-ruby/jruby-openssl/jruby-openssl-0.6.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jruby-openssl/jruby-openssl-0.6.ebuild,v 1.1 2010/01/01 03:41:21 ali_bush Exp $
-
-inherit ruby gems
-
-USE_RUBY="ruby18"
-DESCRIPTION="A Ruby SSL library that works with JRuby"
-HOMEPAGE="http://rubyforge.org/projects/jruby-extras"
-SRC_URI="mirror://rubygems/${P}.gem"
-
-LICENSE="MIT || ( CPL-1.0 GPL-2 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND=">=dev-java/jruby-1.3.1-r1"