summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-29 23:28:15 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-29 23:28:15 +0000
commitf791d4f922c9257d089193cb1a0ba25113b8c08b (patch)
tree47417411034ad2ca2c242841d052c25170cad814 /dev-ruby/inifile
parentAdd ruby20 target. (diff)
downloadgentoo-2-f791d4f922c9257d089193cb1a0ba25113b8c08b.tar.gz
gentoo-2-f791d4f922c9257d089193cb1a0ba25113b8c08b.tar.bz2
gentoo-2-f791d4f922c9257d089193cb1a0ba25113b8c08b.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/inifile')
-rw-r--r--dev-ruby/inifile/ChangeLog10
-rw-r--r--dev-ruby/inifile/inifile-2.0.2-r1.ebuild27
2 files changed, 34 insertions, 3 deletions
diff --git a/dev-ruby/inifile/ChangeLog b/dev-ruby/inifile/ChangeLog
index 359bab6d5ed9..d3c70b372393 100644
--- a/dev-ruby/inifile/ChangeLog
+++ b/dev-ruby/inifile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/inifile
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/inifile/ChangeLog,v 1.5 2012/10/12 05:23:15 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/inifile/ChangeLog,v 1.6 2013/10/29 23:28:15 mrueg Exp $
+
+*inifile-2.0.2-r1 (30 Oct 2013)
+
+ 30 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +inifile-2.0.2-r1.ebuild:
+ Add ruby20 target.
*inifile-2.0.2 (12 Oct 2012)
@@ -23,4 +28,3 @@
29 Dec 2011; Diego E. Pettenò <flameeyes@gentoo.org> +inifile-0.4.1.ebuild,
+metadata.xml:
Initial import of ebuild for .ini file reading.
-
diff --git a/dev-ruby/inifile/inifile-2.0.2-r1.ebuild b/dev-ruby/inifile/inifile-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..254e031e5abd
--- /dev/null
+++ b/dev-ruby/inifile/inifile-2.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/inifile/inifile-2.0.2-r1.ebuild,v 1.1 2013/10/29 23:28:15 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md History.txt"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Native Ruby package for reading and writing INI files."
+HOMEPAGE="https://github.com/TwP/inifile"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -S testrb test/test_*.rb || die
+}