summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-05-15 00:51:50 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-05-15 00:51:50 +0000
commit42e8ccc092ee0be30fb513780cc50b212b82388b (patch)
tree19141a2a824f6b50e7e71af746c3bc13a1dfbce4 /dev-ruby/gnuplot
parentRemove ruby18. (diff)
downloadgentoo-2-42e8ccc092ee0be30fb513780cc50b212b82388b.tar.gz
gentoo-2-42e8ccc092ee0be30fb513780cc50b212b82388b.tar.bz2
gentoo-2-42e8ccc092ee0be30fb513780cc50b212b82388b.zip
Add ruby21 target. Remove ruby18.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/gnuplot')
-rw-r--r--dev-ruby/gnuplot/ChangeLog10
-rw-r--r--dev-ruby/gnuplot/gnuplot-2.6.2-r1.ebuild6
-rw-r--r--dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild32
3 files changed, 43 insertions, 5 deletions
diff --git a/dev-ruby/gnuplot/ChangeLog b/dev-ruby/gnuplot/ChangeLog
index 3d105c7a839e..e1abe0cd9660 100644
--- a/dev-ruby/gnuplot/ChangeLog
+++ b/dev-ruby/gnuplot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/gnuplot
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.21 2013/11/02 19:41:09 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.22 2014/05/15 00:51:50 mrueg Exp $
+
+*gnuplot-2.6.2-r2 (15 May 2014)
+
+ 15 May 2014; Manuel Rüger <mrueg@gentoo.org> +gnuplot-2.6.2-r2.ebuild,
+ gnuplot-2.6.2-r1.ebuild:
+ Add ruby21 target. Remove ruby18.
02 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -gnuplot-2.6.0.ebuild,
-gnuplot-2.6.2.ebuild:
diff --git a/dev-ruby/gnuplot/gnuplot-2.6.2-r1.ebuild b/dev-ruby/gnuplot/gnuplot-2.6.2-r1.ebuild
index 87477a77313f..c67b22096cd8 100644
--- a/dev-ruby/gnuplot/gnuplot-2.6.2-r1.ebuild
+++ b/dev-ruby/gnuplot/gnuplot-2.6.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/gnuplot-2.6.2-r1.ebuild,v 1.1 2013/10/09 01:28:06 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/gnuplot-2.6.2-r1.ebuild,v 1.2 2014/05/15 00:51:50 mrueg Exp $
EAPI=5
-USE_RUBY="ruby18 ruby19 ruby20 jruby"
+USE_RUBY="ruby19 ruby20 jruby"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
diff --git a/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild b/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild
new file mode 100644
index 000000000000..81c9f70c7434
--- /dev/null
+++ b/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild,v 1.1 2014/05/15 00:51:50 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Gnuplot drawing library - Ruby Bindings"
+HOMEPAGE="http://rgplot.rubyforge.org/"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+SLOT="0"
+
+RDEPEND+=" sci-visualization/gnuplot"
+
+all_ruby_prepare() {
+ # Existing metadata causes a crash in jruby, so use our own.
+ rm ../metadata || die "Unable to remove metadata."
+}
+
+each_ruby_test() {
+ ${RUBY} -Ctest test_gnuplot.rb || die
+}