summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-05-15 01:11:34 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-05-15 01:11:34 +0000
commit77c893644ac46af3521f9dffdacd69dffe66173d (patch)
treebf1c2e423367c4fd6125eb6e9cf5125f40ddc5df /dev-ruby/file-tail
parentRemove ruby18. Cleanup old. (diff)
downloadgentoo-2-77c893644ac46af3521f9dffdacd69dffe66173d.tar.gz
gentoo-2-77c893644ac46af3521f9dffdacd69dffe66173d.tar.bz2
gentoo-2-77c893644ac46af3521f9dffdacd69dffe66173d.zip
Remove ruby18. Add ruby21.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/file-tail')
-rw-r--r--dev-ruby/file-tail/ChangeLog10
-rw-r--r--dev-ruby/file-tail/file-tail-1.0.12-r1.ebuild6
-rw-r--r--dev-ruby/file-tail/file-tail-1.0.12-r2.ebuild33
3 files changed, 44 insertions, 5 deletions
diff --git a/dev-ruby/file-tail/ChangeLog b/dev-ruby/file-tail/ChangeLog
index 2ffbf32109c8..852f745dfc7d 100644
--- a/dev-ruby/file-tail/ChangeLog
+++ b/dev-ruby/file-tail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/file-tail
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.12 2013/11/09 19:44:07 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.13 2014/05/15 01:11:34 mrueg Exp $
+
+*file-tail-1.0.12-r2 (15 May 2014)
+
+ 15 May 2014; Manuel Rüger <mrueg@gentoo.org> +file-tail-1.0.12-r2.ebuild,
+ file-tail-1.0.12-r1.ebuild:
+ Remove ruby18. Add ruby21.
09 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -file-tail-1.0.12.ebuild:
Cleanup old.
diff --git a/dev-ruby/file-tail/file-tail-1.0.12-r1.ebuild b/dev-ruby/file-tail/file-tail-1.0.12-r1.ebuild
index 7fd174f2fd2e..c408eb92a437 100644
--- a/dev-ruby/file-tail/file-tail-1.0.12-r1.ebuild
+++ b/dev-ruby/file-tail/file-tail-1.0.12-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/file-tail-1.0.12-r1.ebuild,v 1.1 2013/11/02 20:34:13 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/file-tail-1.0.12-r1.ebuild,v 1.2 2014/05/15 01:11:34 mrueg Exp $
EAPI=5
-USE_RUBY="ruby18 ruby19 ruby20 jruby"
+USE_RUBY="ruby19 ruby20 jruby"
RUBY_FAKEGEM_RECIPE_TEST="none"
diff --git a/dev-ruby/file-tail/file-tail-1.0.12-r2.ebuild b/dev-ruby/file-tail/file-tail-1.0.12-r2.ebuild
new file mode 100644
index 000000000000..5ac6cf4d475d
--- /dev/null
+++ b/dev-ruby/file-tail/file-tail-1.0.12-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/file-tail-1.0.12-r2.ebuild,v 1.1 2014/05/15 01:11:34 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOC_SOURCES="lib README.rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small ruby library that allows it to 'tail' files in Ruby"
+HOMEPAGE="http://flori.github.com/file-tail"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/tins-0.5"
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}