summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-04 06:48:22 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-04 06:48:22 +0000
commit61fc503a0e94fd834c9370b5c1f14eb7466482d4 (patch)
tree671aa5e2232431760bf2785d54911689cdcef704 /dev-ruby/fastercsv
parentversion bump wrt #309861 (diff)
downloadgentoo-2-61fc503a0e94fd834c9370b5c1f14eb7466482d4.tar.gz
gentoo-2-61fc503a0e94fd834c9370b5c1f14eb7466482d4.tar.bz2
gentoo-2-61fc503a0e94fd834c9370b5c1f14eb7466482d4.zip
Version bump with bug fixes.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/fastercsv')
-rw-r--r--dev-ruby/fastercsv/ChangeLog7
-rw-r--r--dev-ruby/fastercsv/fastercsv-1.5.3.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/fastercsv/ChangeLog b/dev-ruby/fastercsv/ChangeLog
index 0927f26196cb..5ced6508932b 100644
--- a/dev-ruby/fastercsv/ChangeLog
+++ b/dev-ruby/fastercsv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fastercsv
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fastercsv/ChangeLog,v 1.7 2010/02/16 07:17:38 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fastercsv/ChangeLog,v 1.8 2010/04/04 06:48:22 graaff Exp $
+
+*fastercsv-1.5.3 (04 Apr 2010)
+
+ 04 Apr 2010; Hans de Graaff <graaff@gentoo.org> +fastercsv-1.5.3.ebuild:
+ Version bump with bug fixes.
*fastercsv-1.5.1 (16 Feb 2010)
diff --git a/dev-ruby/fastercsv/fastercsv-1.5.3.ebuild b/dev-ruby/fastercsv/fastercsv-1.5.3.ebuild
new file mode 100644
index 000000000000..a7cdd8c87dae
--- /dev/null
+++ b/dev-ruby/fastercsv/fastercsv-1.5.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fastercsv/fastercsv-1.5.3.ebuild,v 1.1 2010/04/04 06:48:22 graaff Exp $
+
+EAPI=2
+
+# ruby19 → not needed, it's bundled as part of the main package
+# jruby → tests fail (badly?) for encoding and zlib support (latter
+# fixed in 1.4)
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc/html"
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGELOG README TODO"
+
+inherit ruby-fakegem
+
+ruby_add_bdepend test virtual/ruby-test-unit
+
+DESCRIPTION="FasterCSV is a replacement for the standard CSV library"
+HOMEPAGE="http://fastercsv.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend test virtual/ruby-test-unit
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}